It is currently 25 May 2017, 04:52
   
Text Size

Forge Beta Release: 02-20-2017 ver. 1.5.60

Moderators: timmermac, moomarc, Chris H., DennisBergkamp, Rob Cashwalker, friarsol, CCGHQ Admins

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby Conductor » 13 Mar 2017, 03:01

schnautzr wrote:
Conductor wrote:
schnautzr wrote:Not a bug, but with the release of Kaladesh, the titles of all previously released cards with the word "AEther" were officially changed to use "Aether" without the AE ligature.
I guess that might explain why since installing this new release, any time I try to view the AEther Hub card my game crashes.
Forge's copy doesn't use the ligature. Did you type it with the ligature when you made your decklist?
That's the thing; it's not just when I open a deck containing AEther Hub, it's if I try and search for it in the deck builder too. The game doesn't crash until I bring the card into view. For example, if I filtered down to cards in Kaladesh, it wouldn't crash until I scrolled down to AEther Hub.
Conductor
 
Posts: 4
Joined: 12 Mar 2017, 23:28
Has thanked: 0 time
Been thanked: 0 time

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby Agetian » 13 Mar 2017, 04:29

CokedUpZombie wrote:That's weird...here is a copy of the dck file for my other commander deck and its formatted differently...
[metadata]
Name=Oloro, Ageless Ascetic
[Commander]
1 Oloro, Ageless Ascetic|C13
[Main]
1 Aetherflux Reservoir|KLD
1 Ajani's Mantra|DDH
1 Ajani's Pridemate|M15
1 Ajani, Caller of the Pride|M14
1 Angelic Shield|DDI
1 Archangel of Thune|M14
1 Blackcleave Goblin|SOM
1 Blighted Agent|NPH
1 Blind Obedience|GTC
1 Boon Reflection|SHM
1 Cancel|KTK
1 Cathars' Crusade|C14
1 Caves of Koilos|ORI
1 Celestial Ancient|C15
1 Chalice of Life|DKA
1 Choking Fumes|MBS
1 Command Tower|C15
1 Contagious Nim|SOM
1 Corrupted Conscience|MBS
1 Counterlash|DKA
1 Cradle of Vitality|C13
1 Dawnray Archer|ALA
1 Diabolic Tutor|KLD
1 Dismember|MM2
1 Dissolve|THS
1 Doomwake Giant|C15
1 Drowned Catacomb|M13
1 Essence Scatter|M14
1 Evil Twin|ISD
1 Flensermite|MBS
1 Fuel for the Cause|MBS
1 Glorious Anthem|10E
1 Grim Affliction|MM2
8 Island|SOI|1
1 Isolated Chapel|ISD
1 Karlov of the Ghost Council|C15
1 Languish|ORI
1 Mikaeus, the Lunarch|ISD
1 Mirror-Sigil Sergeant|CFX
1 Mother of Runes|EMA
1 Murder|EMN
1 Necropede|SOM
1 Obelisk of Esper|C13
1 Oblivion Ring|MM2
1 Phyresis|MBS
1 Phyrexian Arena|C15
1 Plague Myr|MBS
1 Plague Stinger|SOM
10 Plains|SOI|1
1 Prairie Stream|EXP
1 Priests of Norn|MBS
1 Pristine Talisman|C14
1 Rebuke|DDQ
1 Recumbent Bliss|DDH
1 Reliquary Tower|C15
1 Remove Soul|10E
1 Revoke Existence|BNG
1 Royal Assassin|M12
1 Scoured Barrens|EMA
1 Seal of Cleansing|EMA
1 Sejiri Refuge|C13
1 Serra Ascendant|M11
1 Shimmering Wings|10E
1 Sigiled Paladin|ALA
1 Sol Ring|C15
1 Spread the Sickness|MM2
1 Sublime Archangel|M13
1 Sunken Hollow|EXP
8 Swamp|SOI|1
1 True Conviction|C14
1 Unsummon|M13
1 Utter End|KTK
1 Viral Drake|NPH
1 Wall of Denial|DDI
1 Wall of Reverence|C13
1 Watery Grave|EXP
Hmm, this exact deck file loads and works just fine on my machine using the Forge 1.5.60 build. This leads me to a suggestion that maybe your Forge installation is borked somehow (or was not updated properly). For example, the problem may be that the "cardsfolder.zip" file and/or one of the editions files was not copied over or updated correctly. Can you try reinstalling Forge in a separate, clean folder? (you can keep your profile and picture cache files, of course).

- Agetian
Agetian
Programmer
 
Posts: 2573
Joined: 14 Mar 2011, 05:58
Has thanked: 507 times
Been thanked: 315 times

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby Agetian » 13 Mar 2017, 04:32

Conductor wrote:That's the thing; it's not just when I open a deck containing AEther Hub, it's if I try and search for it in the deck builder too. The game doesn't crash until I bring the card into view. For example, if I filtered down to cards in Kaladesh, it wouldn't crash until I scrolled down to AEther Hub.
Is there any reason you're staying on an older version of Forge? It doesn't crash in v1.5.60 for sure (just tested it), so maybe you should consider updating? (IIRC you were using 1.5.58 when you reported the issue, which is two releases back).

- Agetian
Agetian
Programmer
 
Posts: 2573
Joined: 14 Mar 2011, 05:58
Has thanked: 507 times
Been thanked: 315 times

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby Agetian » 13 Mar 2017, 04:36

onderzeeboot wrote:Waxmane Baku doesn't tap the targets of its activated ability.
Are you on the latest version of Forge? It does do so for me in v1.5.60. :/ If you're fully updated and it still doesn't work, what are the conditions when it doesn't work for you?

- Agetian
Agetian
Programmer
 
Posts: 2573
Joined: 14 Mar 2011, 05:58
Has thanked: 507 times
Been thanked: 315 times

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby onderzeeboot » 13 Mar 2017, 09:54

Agetian wrote:
onderzeeboot wrote:Waxmane Baku doesn't tap the targets of its activated ability.
Are you on the latest version of Forge? It does do so for me in v1.5.60. :/ If you're fully updated and it still doesn't work, what are the conditions when it doesn't work for you?

- Agetian
I'm on v1.5.60. It was in a MM2 draft, where I had two Waxmane Baku's out. One of them had a single counter on it, the other had no counter on it. If I remember correctly I tried to tap a blocker during my opponent's end of turn step, and that didn't work. I tried it again on his next turn, when both had received a new counter from a fresh Spirit spell I cast, to no avail.
onderzeeboot
 
Posts: 28
Joined: 29 Nov 2014, 19:37
Has thanked: 5 times
Been thanked: 0 time

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby Conductor » 13 Mar 2017, 11:52

Agetian wrote:
Conductor wrote:That's the thing; it's not just when I open a deck containing AEther Hub, it's if I try and search for it in the deck builder too. The game doesn't crash until I bring the card into view. For example, if I filtered down to cards in Kaladesh, it wouldn't crash until I scrolled down to AEther Hub.
Is there any reason you're staying on an older version of Forge? It doesn't crash in v1.5.60 for sure (just tested it), so maybe you should consider updating? (IIRC you were using 1.5.58 when you reported the issue, which is two releases back).

- Agetian
Huh? This didn't start happening until I updated to 1.5.60. I was fine on the previous releases.
Conductor
 
Posts: 4
Joined: 12 Mar 2017, 23:28
Has thanked: 0 time
Been thanked: 0 time

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby CokedUpZombie » 13 Mar 2017, 13:17

Agetian wrote:
CokedUpZombie wrote:That's weird...here is a copy of the dck file for my other commander deck and its formatted differently...
[metadata]
Name=Oloro, Ageless Ascetic
[Commander]
1 Oloro, Ageless Ascetic|C13
[Main]
1 Aetherflux Reservoir|KLD
1 Ajani's Mantra|DDH
1 Ajani's Pridemate|M15
1 Ajani, Caller of the Pride|M14
1 Angelic Shield|DDI
1 Archangel of Thune|M14
1 Blackcleave Goblin|SOM
1 Blighted Agent|NPH
1 Blind Obedience|GTC
1 Boon Reflection|SHM
1 Cancel|KTK
1 Cathars' Crusade|C14
1 Caves of Koilos|ORI
1 Celestial Ancient|C15
1 Chalice of Life|DKA
1 Choking Fumes|MBS
1 Command Tower|C15
1 Contagious Nim|SOM
1 Corrupted Conscience|MBS
1 Counterlash|DKA
1 Cradle of Vitality|C13
1 Dawnray Archer|ALA
1 Diabolic Tutor|KLD
1 Dismember|MM2
1 Dissolve|THS
1 Doomwake Giant|C15
1 Drowned Catacomb|M13
1 Essence Scatter|M14
1 Evil Twin|ISD
1 Flensermite|MBS
1 Fuel for the Cause|MBS
1 Glorious Anthem|10E
1 Grim Affliction|MM2
8 Island|SOI|1
1 Isolated Chapel|ISD
1 Karlov of the Ghost Council|C15
1 Languish|ORI
1 Mikaeus, the Lunarch|ISD
1 Mirror-Sigil Sergeant|CFX
1 Mother of Runes|EMA
1 Murder|EMN
1 Necropede|SOM
1 Obelisk of Esper|C13
1 Oblivion Ring|MM2
1 Phyresis|MBS
1 Phyrexian Arena|C15
1 Plague Myr|MBS
1 Plague Stinger|SOM
10 Plains|SOI|1
1 Prairie Stream|EXP
1 Priests of Norn|MBS
1 Pristine Talisman|C14
1 Rebuke|DDQ
1 Recumbent Bliss|DDH
1 Reliquary Tower|C15
1 Remove Soul|10E
1 Revoke Existence|BNG
1 Royal Assassin|M12
1 Scoured Barrens|EMA
1 Seal of Cleansing|EMA
1 Sejiri Refuge|C13
1 Serra Ascendant|M11
1 Shimmering Wings|10E
1 Sigiled Paladin|ALA
1 Sol Ring|C15
1 Spread the Sickness|MM2
1 Sublime Archangel|M13
1 Sunken Hollow|EXP
8 Swamp|SOI|1
1 True Conviction|C14
1 Unsummon|M13
1 Utter End|KTK
1 Viral Drake|NPH
1 Wall of Denial|DDI
1 Wall of Reverence|C13
1 Watery Grave|EXP
Hmm, this exact deck file loads and works just fine on my machine using the Forge 1.5.60 build. This leads me to a suggestion that maybe your Forge installation is borked somehow (or was not updated properly). For example, the problem may be that the "cardsfolder.zip" file and/or one of the editions files was not copied over or updated correctly. Can you try reinstalling Forge in a separate, clean folder? (you can keep your profile and picture cache files, of course).

- Agetian
This deck works fine. It's my Atraxa deck that won't load.
CokedUpZombie
 
Posts: 19
Joined: 08 Feb 2017, 18:57
Has thanked: 1 time
Been thanked: 0 time

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby CokedUpZombie » 13 Mar 2017, 13:19

I'll just delete it and recreate it.
CokedUpZombie
 
Posts: 19
Joined: 08 Feb 2017, 18:57
Has thanked: 1 time
Been thanked: 0 time

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby Agetian » 13 Mar 2017, 13:59

CokedUpZombie wrote:I'll just delete it and recreate it.
Yeah, either that or at least post the deck that doesn't work here :)

- Agetian
Agetian
Programmer
 
Posts: 2573
Joined: 14 Mar 2011, 05:58
Has thanked: 507 times
Been thanked: 315 times

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby Agetian » 13 Mar 2017, 14:01

Conductor wrote:
Agetian wrote:
Conductor wrote:That's the thing; it's not just when I open a deck containing AEther Hub, it's if I try and search for it in the deck builder too. The game doesn't crash until I bring the card into view. For example, if I filtered down to cards in Kaladesh, it wouldn't crash until I scrolled down to AEther Hub.
Is there any reason you're staying on an older version of Forge? It doesn't crash in v1.5.60 for sure (just tested it), so maybe you should consider updating? (IIRC you were using 1.5.58 when you reported the issue, which is two releases back).

- Agetian
Huh? This didn't start happening until I updated to 1.5.60. I was fine on the previous releases.
Ah, must have been someone else who was on 1.5.58 then. Anyhoo, if that's the case (you updated to 1.5.60 and it started crashing), then make sure your cardsfolder.zip and your editions files were updated correctly, the problem might lie in the fact that your game resources did not get overwritten / updated correctly when you updated to 1.5.60. You can try deleting (or moving somewhere) your "res" folder and extracting a fresh copy from the 1.5.60 archive, see if that changes things for you.

- Agetian
Agetian
Programmer
 
Posts: 2573
Joined: 14 Mar 2011, 05:58
Has thanked: 507 times
Been thanked: 315 times

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby Conductor » 14 Mar 2017, 01:53

Agetian wrote:
Ah, must have been someone else who was on 1.5.58 then. Anyhoo, if that's the case (you updated to 1.5.60 and it started crashing), then make sure your cardsfolder.zip and your editions files were updated correctly, the problem might lie in the fact that your game resources did not get overwritten / updated correctly when you updated to 1.5.60. You can try deleting (or moving somewhere) your "res" folder and extracting a fresh copy from the 1.5.60 archive, see if that changes things for you.

- Agetian
Ok, this is weird. I copied my decks and achievements, wiped, reinstalled clean, put them back, and it ran just fine. But after I ran the LQ card/set content downloaders, I'm back to crashing when scrolling to AEther Hub. I managed to save a crash report this time, if that helps.
Attachments
AEther Hub Crash 2017-03-13-00.txt
(2.25 KiB) Downloaded 18 times
Conductor
 
Posts: 4
Joined: 12 Mar 2017, 23:28
Has thanked: 0 time
Been thanked: 0 time

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby friarsol » 14 Mar 2017, 02:20

Conductor wrote:Ok, this is weird. I copied my decks and achievements, wiped, reinstalled clean, put them back, and it ran just fine. But after I ran the LQ card/set content downloaders, I'm back to crashing when scrolling to AEther Hub. I managed to save a crash report this time, if that helps.
Sounds like your Aether Hub art is corrupted and is crashing your Forge. I'll check to see if there's something wrong with the download.
friarsol
Global Moderator
 
Posts: 7047
Joined: 15 May 2010, 04:20
Has thanked: 225 times
Been thanked: 838 times

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby Agetian » 14 Mar 2017, 07:20

friarsol wrote:
Conductor wrote:Ok, this is weird. I copied my decks and achievements, wiped, reinstalled clean, put them back, and it ran just fine. But after I ran the LQ card/set content downloaders, I'm back to crashing when scrolling to AEther Hub. I managed to save a crash report this time, if that helps.
Sounds like your Aether Hub art is corrupted and is crashing your Forge. I'll check to see if there's something wrong with the download.
Either that or there's something up with whatever file is attempted for download when the LQ card/set downloader is fired. :/ You can also check to see if maybe Aether Hub.full.jpg / AEther Hub.full.jpg file in your picture cache is corrupt (and then you can replace it with a different one, e.g. download a HQ picture archive for the appropriate set from the Pictures forum).

- Agetian
Agetian
Programmer
 
Posts: 2573
Joined: 14 Mar 2011, 05:58
Has thanked: 507 times
Been thanked: 315 times

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby CokedUpZombie » 14 Mar 2017, 22:36

Agetian wrote:
CokedUpZombie wrote:I'll just delete it and recreate it.
Yeah, either that or at least post the deck that doesn't work here :)

- Agetian
I posted two decks total. Oloro deck that works fine and the Atraxa that doesn't....just wanted to be clear.
CokedUpZombie
 
Posts: 19
Joined: 08 Feb 2017, 18:57
Has thanked: 1 time
Been thanked: 0 time

Re: Forge Beta Release: 02-20-2017 ver. 1.5.60

Postby leshrac » 15 Mar 2017, 00:50

This bug is pretty old i guess: Sylvan Library doesn't let you choose the order of the cards you put back. From my testing, it seems it always asks for the first card drawn out of the two you choose first and then the second one, no matter in which order you actually clicked on the cards.

(Idea how you could make it work: Have the user click just one card and then choose what to do with it, then repeat.)
leshrac
 
Posts: 25
Joined: 31 Dec 2014, 00:05
Has thanked: 1 time
Been thanked: 0 time

PreviousNext

Return to Forge

Who is online

Users browsing this forum: No registered users and 7 guests


Who is online

In total there are 7 users online :: 0 registered, 0 hidden and 7 guests (based on users active over the past 10 minutes)
Most users ever online was 279 on 11 Jul 2013, 22:03

Users browsing this forum: No registered users and 7 guests

Login Form