It is currently 15 Apr 2021, 23:54
   
Text Size

Can't open bat file to run forge

Moderators: timmermac, friarsol, Blacksmith, KrazyTheFox, Agetian, CCGHQ Admins

Can't open bat file to run forge

Postby peepser » 03 Jan 2020, 19:42

Running a bat file to use more ram in forge. Always worked on my win 7 system Now using win 10 and all i get is a brief flash of the command prompt, but forge won't open. tried running as admin and the text format is also correct. Any ideas?

I put a pause in the command, and it says '-xmx4096 exceeds the max representable size'

Always worked before. have 16 gigs ram.

edit: found the problem. I was using 32 bit java which does not allow more than 1 gig in the heap. Installed Java 64 and it works again.

It's interesting that my new UFO pc system will run forge really fast for about one gauntlet (much smoother than my 2013 pc) but then starts stalling out again, even with 16 gigs ram. You have to use the bat file to allow more java ram for longer game sessions.
peepser
 
Posts: 184
Joined: 14 Aug 2018, 22:30
Has thanked: 18 times
Been thanked: 10 times

Re: Can't open bat file to run forge

Postby CptKird » 03 Jan 2020, 23:27

Yes, 64bit Java for a 64bit OS would've been my first choice as well ;)

Also if you didn't install Java in its default path, that would have borked the default system variables.
(which could be manually edited, of course)

But yea, go nuts with the heap size. Also, reduce scan resolution and bit depth, works wonders.

See: https://www.slightlymagic.net/forum/viewtopic.php?f=52&t=29089#p240448

K.
User avatar
CptKird
 
Posts: 180
Joined: 02 Nov 2017, 17:25
Has thanked: 36 times
Been thanked: 28 times


Return to Forge

Who is online

Users browsing this forum: No registered users and 15 guests

cron

Who is online

In total there are 15 users online :: 0 registered, 0 hidden and 15 guests (based on users active over the past 10 minutes)
Most users ever online was 1371 on 09 Feb 2020, 16:22

Users browsing this forum: No registered users and 15 guests

Login Form