It is currently 14 Oct 2019, 08:15
   
Text Size

Import problem with ROE

by Nate

Moderators: Snacko, CCGHQ Admins

Re: Import problem with ROE

Postby kristijanH » 25 Apr 2010, 16:59

Same problem. I don't get any errors. It's just that the program doesn't start. I used a fresh install rc6 and the test file.
kristijanH
 
Posts: 218
Joined: 24 Nov 2009, 13:49
Has thanked: 52 times
Been thanked: 11 times

Re: Import problem with ROE

Postby Snacko » 25 Apr 2010, 17:15

Ah the problem is 6.3 is an update to 6.2, and this is an update to 6.3. However 6.2 version was deleted, because I thought 6.3 was a full package.

I'll be packaging 6.3 soon, when I filter out other languages.
Snacko
DEVELOPER
 
Posts: 826
Joined: 29 May 2008, 19:35
Has thanked: 4 times
Been thanked: 73 times

Re: Import problem with ROE

Postby Burnf » 26 Apr 2010, 12:32

Sweet! Clearing that config file fixed it.
Thanks Snacko!

I'm going to give it a try, but just thought I'd post the question. Is it safe to copy this new deck builder data files over to the cardgen to get the cardgen working with ROE?
Burnf
 
Posts: 130
Joined: 06 Mar 2009, 15:16
Has thanked: 0 time
Been thanked: 0 time

Re: Import problem with ROE

Postby Snacko » 26 Apr 2010, 17:52

Yes, it should work. Maybe cards that got a/b might not be working correctly as they would need images renaming like Card name (a).jpg.
Snacko
DEVELOPER
 
Posts: 826
Joined: 29 May 2008, 19:35
Has thanked: 4 times
Been thanked: 73 times

Re: Import problem with ROE

Postby Burnf » 28 Apr 2010, 18:46

I noticed that my version of deckbuilder doesn't seem to have basic lands anymore. Not sure if anything else is missing.
Burnf
 
Posts: 130
Joined: 06 Mar 2009, 15:16
Has thanked: 0 time
Been thanked: 0 time

Re: Import problem with ROE

Postby Snacko » 29 Apr 2010, 18:01

There were basic lands, but they were filtered out when option 'only unique' was checked.
Try this and see if there are any more bugs:
http://www.mediafire.com/file/m3mhmqzzn ... gv3-ROE.7z

If it works then I'll probably have the full package with all the languages around weekend.
Snacko
DEVELOPER
 
Posts: 826
Joined: 29 May 2008, 19:35
Has thanked: 4 times
Been thanked: 73 times

Re: Import problem with ROE

Postby Burnf » 30 Apr 2010, 10:28

I have basic lands!
Thanks Snacko!
Burnf
 
Posts: 130
Joined: 06 Mar 2009, 15:16
Has thanked: 0 time
Been thanked: 0 time

Re: Import problem with ROE

Postby Bog Wraith » 07 May 2010, 18:26

Not sure if this was covered elsewhere but I am getting a weird bug that refers to the english.lang which prevents Arcane from loading:


arcane.ArcaneException: File not found: "data/english.lang".
at arcane.ArcaneTranslation.<init>(ArcaneTranslation.java:20)
at arcane.Arcane$DataLoader.load(Arcane.java:427)
at arcane.util.Loader.run(Loader.java:95)
at java.lang.Thread.run(Thread.java:613)
Caused by: java.io.FileNotFoundException: data/english.lang (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:106)
at java.io.FileInputStream.<init>(FileInputStream.java:66)
at arcane.ArcaneTranslation.<init>(ArcaneTranslation.java:16)
... 3 more

arcane.ArcaneException: File not found: "data/english.lang".
at arcane.ArcaneTranslation.<init>(ArcaneTranslation.java:20)
at arcane.Arcane$DataLoader.load(Arcane.java:427)
at arcane.util.Loader.run(Loader.java:95)
at java.lang.Thread.run(Thread.java:613)
Caused by: java.io.FileNotFoundException: data/english.lang (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:106)
at java.io.FileInputStream.<init>(FileInputStream.java:66)
at arcane.ArcaneTranslation.<init>(ArcaneTranslation.java:16)
... 3 more
arcane.ArcaneException: Arcane initialization aborted.
at arcane.Arcane.setup(Arcane.java:109)
at arcane.deckbuilder.ui.DeckBuilder.main(DeckBuilder.java:2705)

Everything was running perfectly until this ROE update on both my Mac's.
'Twas in the bogs of Cannelbrae
My mate did meet an early grave
'Twas nothing left for us to save
In the peat-filled bogs of Cannelbrae.
User avatar
Bog Wraith
Global Mod 1 (Ret)
 
Posts: 1100
Joined: 28 May 2008, 22:40
Location: Shandalar
Has thanked: 420 times
Been thanked: 150 times

Re: Import problem with ROE

Postby Snacko » 07 May 2010, 20:32

Swap the arcane.jar in lib folder with this.

The file could be used to translate the whole UI of the deckbuilder and rulesviewer into any language, but so far only the Menu has been covered as I didn't spend any time to finish this feature.

I'll have a full ROE package really soon I hope!
Snacko
DEVELOPER
 
Posts: 826
Joined: 29 May 2008, 19:35
Has thanked: 4 times
Been thanked: 73 times

Re: Import problem with ROE

Postby Bog Wraith » 07 May 2010, 22:29

Still no joy! After applying this and the ROE update I get this bug report:


arcane.ArcaneException: Invalid picture number "Right" for card: B.F.M.
at arcane.Card.<init>(Card.java:137)
at arcane.CardDataStore.populate(CardDataStore.java:152)
at arcane.Arcane$DataLoader.loadCardData(Arcane.java:509)
at arcane.Arcane$DataLoader.load(Arcane.java:455)
at arcane.util.Loader.run(Loader.java:95)
at java.lang.Thread.run(Thread.java:613)

arcane.ArcaneException: Invalid picture number "Right" for card: B.F.M.
at arcane.Card.<init>(Card.java:137)
at arcane.CardDataStore.populate(CardDataStore.java:152)
at arcane.Arcane$DataLoader.loadCardData(Arcane.java:509)
at arcane.Arcane$DataLoader.load(Arcane.java:455)
at arcane.util.Loader.run(Loader.java:95)
at java.lang.Thread.run(Thread.java:613)
arcane.ArcaneException: Arcane initialization aborted.
at arcane.Arcane.setup(Arcane.java:111)
at arcane.deckbuilder.ui.DeckBuilder.main(DeckBuilder.java:2711)

Think I will wait for the full ROE package when it's ready. Thanks for your quick response! :)
'Twas in the bogs of Cannelbrae
My mate did meet an early grave
'Twas nothing left for us to save
In the peat-filled bogs of Cannelbrae.
User avatar
Bog Wraith
Global Mod 1 (Ret)
 
Posts: 1100
Joined: 28 May 2008, 22:40
Location: Shandalar
Has thanked: 420 times
Been thanked: 150 times

Previous

Return to Deck Builder and Excellent Rules Viewer

Who is online

Users browsing this forum: No registered users and 1 guest


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 10 minutes)
Most users ever online was 287 on 31 Mar 2019, 04:11

Users browsing this forum: No registered users and 1 guest

Login Form