It is currently 06 Dec 2019, 03:49
   
Text Size

GUI for 2.9.5 update

by Harry Pitfall

Moderator: CCGHQ Admins

GUI for 2.9.5 update

Postby HarryPitfall » 25 Aug 2008, 03:42

Hello fellow friends, I bring some news... :)
GUI Generator, compatible with 2.9.5 (latest) update (planeswalker). I even make my own ajani vengeant on it.
I bring more, the 2+color hybrid mana (reaper king aproves) on my update.
I have more, but not here, if someone wants:
* Futureshifted Frames, All Borders, Cards, Lands, PT, symbols (except planeswalker, do'h), and textless.
* Tokens: All post-8th gold borders, normal colors and Hybrid with large textbox (I didn't extract the textless and the small text box, sorry)

Get Ready: http://rapidshare.com/files/139895130/M ... r.zip.html

oh, my generator uses the futureshifted and tokens resources as well... :) LOL
HarryPitfall
AI Programmer
 
Posts: 175
Joined: 31 May 2008, 00:14
Has thanked: 1 time
Been thanked: 3 times

Re: GUI for 2.9.5 update

Postby staggerwingjtstw » 25 Aug 2008, 18:03

This is awesome! I was just wondering if anyone's tried creating an Elder Dragon like Chromium with the future-shift frame? I'm wonderig because there's 7mana symbols and that would put the last symbol right behind the text that says "Legendary Creature - Elder Dragon"
User avatar
staggerwingjtstw
 
Posts: 181
Joined: 31 May 2008, 18:03
Has thanked: 3 times
Been thanked: 1 time

Re: GUI for 2.9.5 update

Postby HarryPitfall » 25 Aug 2008, 23:29

If you try to use more than 6 symbols, the generators gives a error when render futureshifted cards.
Also, i update the .js file, when you try to render some cards, you get a 'undefined' error.
Attachments
MagicProxyGeneratorScript.zip
(16.75 KiB) Downloaded 522 times
HarryPitfall
AI Programmer
 
Posts: 175
Joined: 31 May 2008, 00:14
Has thanked: 1 time
Been thanked: 3 times

Re: GUI for 2.9.5 update

Postby HarryPitfall » 26 Aug 2008, 19:39

A sample of generator current state (no futureshifted or token)
Attachments
mywork.jpg
HarryPitfall
AI Programmer
 
Posts: 175
Joined: 31 May 2008, 00:14
Has thanked: 1 time
Been thanked: 3 times

Re: GUI for 2.9.5 update

Postby HarryPitfall » 27 Aug 2008, 15:39

And if you don't believe, planeswalkers overlays too! (And some minor tweaks)
Attachments
Ajani Vengeant.jpg
MagicProxyGeneratorScript.zip
(17 KiB) Downloaded 465 times
HarryPitfall
AI Programmer
 
Posts: 175
Joined: 31 May 2008, 00:14
Has thanked: 1 time
Been thanked: 3 times

Re: GUI for 2.9.5 update

Postby staggerwingjtstw » 27 Aug 2008, 20:14

Sometimes I wish I was as awesome as you. =D>

The rest of the time I wish I was a cat.
I like being bad... it makes me happy...
User avatar
staggerwingjtstw
 
Posts: 181
Joined: 31 May 2008, 18:03
Has thanked: 3 times
Been thanked: 1 time

Re: GUI for 2.9.5 update

Postby Huggybaby » 27 Aug 2008, 22:17

Thanks HP!

Question: what is MagicProxyGeneratorScript.zip used for?
User avatar
Huggybaby
Administrator
 
Posts: 3091
Joined: 15 Jan 2006, 19:44
Location: Finally out of Atlanta
Has thanked: 589 times
Been thanked: 574 times

Re: GUI for 2.9.5 update

Postby HarryPitfall » 28 Aug 2008, 00:15

Inside that zip, you get a updated magicproxygenerator.js, is the code that renders the card.
I made the application into 2 tiers, the application itself, that rarely needs a update, and the js render code, small, that can updated and changed fast (and is small too).
Just unpack it over the old .js file and all is fine :)
HarryPitfall
AI Programmer
 
Posts: 175
Joined: 31 May 2008, 00:14
Has thanked: 1 time
Been thanked: 3 times

Re: GUI for 2.9.5 update

Postby heavensblade23 » 29 Aug 2008, 15:40

Looks like this bugs out if you install the latest version of the commandline stuff.
heavensblade23
 
Posts: 14
Joined: 28 Aug 2008, 01:55
Has thanked: 0 time
Been thanked: 0 time

Re: GUI for 2.9.5 update

Postby HarryPitfall » 29 Aug 2008, 16:51

Sounds VERY strange... i have the 2.9.5 update here and works fine, even the overlay for planeswalker is rendered correct (latest js file)
HarryPitfall
AI Programmer
 
Posts: 175
Joined: 31 May 2008, 00:14
Has thanked: 1 time
Been thanked: 3 times

Re: GUI for 2.9.5 update

Postby heavensblade23 » 29 Aug 2008, 20:49

HarryPitfall wrote:Sounds VERY strange... i have the 2.9.5 update here and works fine, even the overlay for planeswalker is rendered correct (latest js file)
I'm talking about 8.2.6 which is the next update after 2.9.5. I was getting error messages all over the place until I started over and just used 2.9.5.
heavensblade23
 
Posts: 14
Joined: 28 Aug 2008, 01:55
Has thanked: 0 time
Been thanked: 0 time

Re: GUI for 2.9.5 update

Postby Huggybaby » 01 Sep 2008, 04:44

I'm using the latest OK, but haven't really stress tested it. What errors do you get, and how do you make them?

Installation sequence is also important, you can install HP's updates before or after 8.2.6. I'm guessing it should be after.
User avatar
Huggybaby
Administrator
 
Posts: 3091
Joined: 15 Jan 2006, 19:44
Location: Finally out of Atlanta
Has thanked: 589 times
Been thanked: 574 times

Re: GUI for 2.9.5 update

Postby Peter Allen » 17 Aug 2010, 11:51

some planeswalker cards have different border sizes than the standard. do we have an update on that? thanks!
Peter Allen
 
Posts: 3
Joined: 17 Aug 2010, 05:07
Has thanked: 0 time
Been thanked: 0 time


Return to HQ Card Generator GUI

Who is online

Users browsing this forum: No registered users and 1 guest


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 10 minutes)
Most users ever online was 564 on 05 Dec 2019, 12:05

Users browsing this forum: No registered users and 1 guest

Login Form