It is currently 19 Mar 2019, 21:02
   
Text Size

Can't create a DirectPlay session on that service provider.

Downloads, Guides , General Support
PLEASE "SEARCH" BEFORE YOU POST!

Moderators: BAgate, drool66, stassy, Aswan jaguar, gmzombie, CCGHQ Admins

Can't create a DirectPlay session on that service provider.

Postby xav » 12 Jul 2009, 03:27

I set up manalink on one computer and i can connect to LAN using my LAN IP, but somehow, it doesn't work on other computers. i'm getting this error message everytime.

@ERROR009
1
E009: Sorry, but I can't create a DirectPlay session on that service provider.

Can anyone help me please?
xav
 
Posts: 1
Joined: 12 Jul 2009, 03:22
Has thanked: 0 time
Been thanked: 0 time

Re: Can't create a DirectPlay session on that service provid

Postby Huggybaby » 22 Mar 2010, 04:53

This post was in the wrong forum (FAQ), Hopefully it will get some attention now, since I've been contacted by a new user with the same issue.

And what is "That Service Provider"? Not the TEN network I hope.
User avatar
Huggybaby
Administrator
 
Posts: 3081
Joined: 15 Jan 2006, 19:44
Location: Finally out of Atlanta
Has thanked: 577 times
Been thanked: 572 times

Re: Can't create a DirectPlay session on that service provid

Postby FerretallicA » 23 Mar 2010, 09:52

What the fuck? My account got deleted... no warning or anything? Had to re-register just to answer this...

Anyway in ManaLink when you go to create a session, make sure you choose options first and disable the two auto- connection options. You'll be prompted on whether or not to host or join a session when you connect now. I haven't been able to get hosting to work at all, but if you 'connect' to your own IP address it effectively creates a host anyway, then the other player can connect to your IP address too.

It's not the most intuitive from there either. It took me and a friend about half an hour to get an actual game started, but at least it works (using the recent CD release torrent and Win 7).
FerretallicA
 
Posts: 3
Joined: 23 Mar 2010, 09:47
Has thanked: 0 time
Been thanked: 2 times

Re: Can't create a DirectPlay session on that service provid

Postby Huggybaby » 23 Mar 2010, 13:03

I'm not sure when you registered, but we lost a lot of accounts when we had a hard drive crash a couple of months ago. So don't take it personally, you weren't the only one.

Thanks for the advice, I hope it helps others with this problem, Maybe someone will write a detailed procedure.

And welcome back to the forum.

<edit> Salinnar over at Demonoid has gotten Multiplayer working and has written a nice procedure, so without further ado, here is Salinnar:

:D Multiplayer now works!!!

Thanks for the support, HB :)

You folks need to make sure that you download the registry entries for this game that put into and out of multiplayer capable mode. These files are provided here: http://www.mediafire.com/?zonttjmzqzq

Ignore everything in that download other than the three .reg files it contains.

First, you need to put these 3 files into the "C:\Program Files\MagicTG" directory where you should have installed the game.

Second, double click/run the magic.reg file just to ensure that the entries were properly placed when you installed the game.

Third, choose which mode you want to run in but running either serial.reg (for single player mode) or no-serial.reg (for multiplayer mode).

For most this will conclude the steps you need to take towards a Masters degree in software engineering ;)

If you open the game at this point and DO NOT see the blue gem in the top right of your screen, you'll need to heed this fourth step. Go to your start menu and run regedit to open your registry. HKEY_USERS\S-1-5-21-xxxxxxxxx\Software\MicroProse\Magic: The Gathering. The Manalink key should have a value of ON not OFF. Just double-click on Manalink and edit the value to ON in the pop-up window. Close the registry (there is no save requirement when you're in the registry).

That's the end of the hard stuff.

Open the game.

Right click on the Manalink gem and choose Preferences -> Options.

Uncheck/Clear 'Use Autoconnect' and click APPLY.

Now just double-click the gem or right-click and choose OPEN.

What opens is the Manalink program. Choose TCP/IP regardless of whether you're playing on a home network (LAN) or over the internet and click the CONNECT button.

Choose to Host or Join.

If you choose Join and are playing a LAN game, leave the next pop-up window blank that requests for you to enter an IP address. The game will find another computer on the network running Manalink for you :)

The rest of the process is rather intuitive so I'll end the text wall here :)

Enjoy!
User avatar
Huggybaby
Administrator
 
Posts: 3081
Joined: 15 Jan 2006, 19:44
Location: Finally out of Atlanta
Has thanked: 577 times
Been thanked: 572 times

Re: Can't create a DirectPlay session on that service provid

Postby aarona68 » 04 Jul 2010, 14:36

Ah, so someone has made a post about this. Sorry about the new post then. However, this process does not work. I have manalink on, and I am running the correct file, however, when I leave that field blank, I still get the message that was quoted at the top of the page.
aarona68
 
Posts: 5
Joined: 04 Jul 2010, 04:58
Has thanked: 0 time
Been thanked: 0 time

Re: Can't create a DirectPlay session on that service provid

Postby stuffdogg » 10 Jul 2010, 03:59

seems there is a problem with the multiplayer on the 2010 iso version of the game on some computers. Has anyone identified the source of these e009 errors? The first laptop I tried this on seems to create a host sesson fine but My other laptop gives me the e009 error even after uninstalling everything and starting from scratch several times. My computer at my office also gives me the same e009 error. And yes I have used the multiplayer fix. Why does it work only on certain computers? All my computers are running exact same xp pro service pack 3! Is it hardware related??? Network cards???? also I tried installing the underdogs version of the game on my e009 error laptop. I think it has mana link version 1.3.2 or something of the sort. I did not try to play a match but it connect with my laptop that was running the iso version of the game with mana link 2.1. but then when I uninstalled it and put the iso version back on it, it gave me the e009 error again. Grrrr. anyone got any ideals.
stuffdogg
 
Posts: 23
Joined: 10 Jul 2010, 03:33
Has thanked: 0 time
Been thanked: 0 time

Re: Can't create a DirectPlay session on that service provid

Postby stassy » 10 Jul 2010, 04:06

The main issue I had was a firewall one, had to disable all of them to let it through.
stassy
Moderator
 
Posts: 5274
Joined: 25 Feb 2009, 07:06
Has thanked: 471 times
Been thanked: 337 times

Re: Can't create a DirectPlay session on that service provid

Postby stuffdogg » 10 Jul 2010, 04:22

Thanks, thought of that, I have all firewalls off. There must be something else.
stuffdogg
 
Posts: 23
Joined: 10 Jul 2010, 03:33
Has thanked: 0 time
Been thanked: 0 time

Re: Can't create a DirectPlay session on that service provid

Postby stuffdogg » 11 Jul 2010, 02:04

Well I got it to work. I think my problem was that when I did the multiplayer fix program, I ran the files from inside winrar instead of extracting them first. I did not think anything of it at the time because It said the registry entries were created successfully but I don't think it really worked correctly. After I did it the correct way it all worked and I have working multiplayer! :)
stuffdogg
 
Posts: 23
Joined: 10 Jul 2010, 03:33
Has thanked: 0 time
Been thanked: 0 time

Re: Can't create a DirectPlay session on that service provid

Postby roadmaster » 11 Sep 2010, 09:10

I had my manalink 2.0 working good then i started to get alot of crashes so i re-installed it, then I started getting the above error E009 DirectPlay so I went back and followed all the instructions to get it working again but this time no matter what I did I could not get past that error. So I started thinking about everything that might be different, thats when I realized I had never Created and Saved a Player for myself after I did the re-install, so I figured what the hey, well after creating a new Player and with all of the above Registry fixes guess what? I got past the E009 Error. So if anyone is still having problems after doing the registry fixes do a check and see if you created a player or not. I hope this helps.

I guess if you dont have a Player Profile it wont let you play ManaLink 2.0

I also have Vista 64 so that may be part of it too.

roadmaster
roadmaster
 
Posts: 1
Joined: 11 Sep 2010, 08:56
Has thanked: 0 time
Been thanked: 0 time

Re: Can't create a DirectPlay session on that service provid

Postby morgium » 14 Feb 2011, 19:11

I had the same problem, and everyone who got here via google or something: Its the Player-thing!
create a Player avatar in the Magic main menu (bottom button), and you can create a session!
morgium
 
Posts: 1
Joined: 14 Feb 2011, 19:10
Has thanked: 0 time
Been thanked: 0 time

Re: Can't create a DirectPlay session on that service provid

Postby heartofdestany » 27 Apr 2015, 13:11

The link to the 3 files mentioned earlier is broken, I am trying to get multiplayer to work could you please reupload these files?
"Isn't the shortest route through the canyon?"
"Yes."
"So shouldn't we—"
"No."
User avatar
heartofdestany
 
Posts: 29
Joined: 25 Nov 2010, 13:51
Has thanked: 5 times
Been thanked: 1 time

Re: Can't create a DirectPlay session on that service provid

Postby gmzombie » 27 Apr 2015, 18:01

multiplayer has been broken for a long time. if i recall it only worked for non recoded cards anyways. sorry bud but it hasent been fixed.
can I maze of ith your snowstorm?

http://home.comcast.net/~gmzombie/index.html old stuff in here. don't use this stuff right now till I get time to get back into it and readjust.
gmzombie
 
Posts: 855
Joined: 26 Feb 2009, 01:05
Location: Wyoming, Mi
Has thanked: 199 times
Been thanked: 50 times

Re: Can't create a DirectPlay session on that service provid

Postby Aswan jaguar » 28 Apr 2015, 06:55

heartofdestany wrote:The link to the 3 files mentioned earlier is broken, I am trying to get multiplayer to work could you please reupload these files?
I don't know about these 3 files but if you do the following as mentioned in manalink2/wiki everything should work:

Add a key to Windows Registry:

After installation create a new file with your windows-editor and paste this content in it:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\MicroProse]

[HKEY_CURRENT_USER\Software\MicroProse\Magic: The Gathering]
"manalink"="on"


Save the file as Magic.reg and run it. When Windows asks you "Are you sure you want to add contents in Magic.reg to registry" - be sure to answer "Yes".


You can expect to have many crashes.If you make it work please give feedback about what works and what not.
---
Just playtesting.
User avatar
Aswan jaguar
Super Tester
 
Posts: 6084
Joined: 13 May 2010, 12:17
Has thanked: 527 times
Been thanked: 274 times

Re: Can't create a DirectPlay session on that service provid

Postby deamastad » 15 Jun 2015, 16:25

this is the same error i keep getting. i got manalink 2.0 to work for multi player if i create player, turn off auto-connect, create as host, then with second computer on same network search for host. works great. couple cards have flaws but thats all the problems ive seen. but if I try to key in the IP address of host, if im on same network or not it gives the error 009 cant create a directplay. it works between the 2 computers when on the same network and i dont type ip so i know its not a version or OS issue. anyone know how to fix this?
deamastad
 
Posts: 4
Joined: 09 Jun 2015, 17:39
Has thanked: 2 times
Been thanked: 0 time

Next

Return to Installation and Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 10 minutes)
Most users ever online was 279 on 11 Jul 2013, 22:03

Users browsing this forum: No registered users and 1 guest

Login Form