It is currently 23 Jul 2019, 11:05
   
Text Size

Deck won't appear

Moderators: Xander9009, CCGHQ Admins

Deck won't appear

Postby Master Necro » 27 Apr 2013, 07:07

I have finally made my own deck, and of course it doesn't work. =D> :x :lol:

Please help and tell me where did I go wrong, I used Odric deck as a base.

my deck.rar
Please Help
(11.65 MiB) Downloaded 95 times
User avatar
Master Necro
 
Posts: 259
Joined: 24 Apr 2013, 18:25
Has thanked: 83 times
Been thanked: 21 times

Re: Deck won't appear

Postby thefiremind » 27 Apr 2013, 09:55

You forgot to edit the various header files. Your deck is called DECK_KAMIGAWA_SUN now, so you need to change all the occurrences of DECK_0007_ST with DECK_KAMIGAWA_SUN in the @header.xml file and in the two HEADER.XML files (better doing it also in APPINFOFILE_DEFAULT.XML, even if RiiakShiNal reported that the deck works even without that file, if I remember correctly).

After that, the deck should work, but if you want to "slim" it a little, you can remove the SOUNDS and SPECIALFX folders, and remove anything from the ART_ASSETS folder that isn't custom: there's no need to repeat any file between WADs because each WAD "sees" each other (original decks do that, but probably just because the developers wanted to make independent decks).
< Former DotP 2012/2013/2014 modder >
Currently busy with life...
User avatar
thefiremind
Programmer
 
Posts: 3515
Joined: 07 Nov 2011, 10:55
Has thanked: 118 times
Been thanked: 717 times

Re: Deck won't appear

Postby Master Necro » 27 Apr 2013, 19:27

Yeah it seems like I'm an idiot, I've done what you asked and now I can see my deck. The only problem is no creature cards that I codded in are appearing, only spells. I don't have the slightest idea why.
User avatar
Master Necro
 
Posts: 259
Joined: 24 Apr 2013, 18:25
Has thanked: 83 times
Been thanked: 21 times

Re: Deck won't appear

Postby thefiremind » 27 Apr 2013, 19:55

I opened Araba Mothrider (the first creature I saw) and found this:
Code: Select all
  <CASTING_COST cost="(1){W}" />
The parentheses around the 1 are wrong. Search the cards you can't see for errors like this.
< Former DotP 2012/2013/2014 modder >
Currently busy with life...
User avatar
thefiremind
Programmer
 
Posts: 3515
Joined: 07 Nov 2011, 10:55
Has thanked: 118 times
Been thanked: 717 times

Re: Deck won't appear

Postby Master Necro » 27 Apr 2013, 20:06

Yep checked all the cards and all the parentheses in cost are now {} and they still don't appear..
User avatar
Master Necro
 
Posts: 259
Joined: 24 Apr 2013, 18:25
Has thanked: 83 times
Been thanked: 21 times

Re: Deck won't appear

Postby thefiremind » 27 Apr 2013, 20:56

You are probably missing some other elements of the XML structure. I dragged and dropped Araba Mothrider on Firefox and it warned that the last <TRIGGERED_ABILITY> doesn't have its </TRIGGERED_ABILITY>.

Always remember this:
thefiremind wrote:Except for the first line of the XML file which is a sort of header, the rest of the file always follows the same rules:
Code: Select all
<BLOCK_THAT_CONTAINS_SOMETHING>
  <ANOTHER_BLOCK_THAT_CONTAINS_SOMETHING tag_name="tag_value">
     <![CDATA[Here you can write special characters]]>
  </ANOTHER_BLOCK_THAT_CONTAINS_SOMETHING>
</BLOCK_THAT_CONTAINS_SOMETHING>
<BLOCK_THAT_DOESNT_CONTAIN_ANYTHING />
So, XML blocks can contain other blocks, or text, or nothing, and can contain tags (other information) where the block starts. <![CDATA[...]> is used when you need to insert special characters (Japanese for example). Code doesn't need that, and official cards don't put code inside <![CDATA[...]> (but you can do it, if you want).
< Former DotP 2012/2013/2014 modder >
Currently busy with life...
User avatar
thefiremind
Programmer
 
Posts: 3515
Joined: 07 Nov 2011, 10:55
Has thanked: 118 times
Been thanked: 717 times

Re: Deck won't appear

Postby Master Necro » 27 Apr 2013, 21:11

Yes that was it! I copied the bushido skill wrong.

Thank you once again! now it all works! :)

I will put the new decks up for download soon. :)

Just one more thing, how do I make the names appear without the brackets?
User avatar
Master Necro
 
Posts: 259
Joined: 24 Apr 2013, 18:25
Has thanked: 83 times
Been thanked: 21 times

Re: Deck won't appear

Postby thefiremind » 27 Apr 2013, 21:49

Master Necro wrote:Just one more thing, how do I make the names appear without the brackets?
You need to define localised text that will substitute that name in brackets with the one in the appropriate language. This is done with Excel-style XMLs to be put in the DATA_ALL_PLATFORMS\TEXT_PERMANENT directory of your deck WAD. Just copy one of those XMLs from some other modder's deck, change its name, open it with Excel or Notepad, and define your localised text.

Here's an example.
Attachments
DECK_TEXT_KAMIGAWA_SUN.zip
(1.18 KiB) Downloaded 93 times
< Former DotP 2012/2013/2014 modder >
Currently busy with life...
User avatar
thefiremind
Programmer
 
Posts: 3515
Joined: 07 Nov 2011, 10:55
Has thanked: 118 times
Been thanked: 717 times

Re: Deck won't appear

Postby Master Necro » 28 Apr 2013, 06:07

I've put the file you gave me but it still shows me [DECK_KAMIGAWA_SUN] as the name of the deck.
User avatar
Master Necro
 
Posts: 259
Joined: 24 Apr 2013, 18:25
Has thanked: 83 times
Been thanked: 21 times

Re: Deck won't appear

Postby thefiremind » 29 Apr 2013, 14:16

Master Necro wrote:I've put the file you gave me but it still shows me [DECK_KAMIGAWA_SUN] as the name of the deck.
I downloaded your deck from your new topic but I see you didn't use the file I gave you... you used another XML where "Kamigawa Sun" is set to replace PLAYER_NAME_KONDA, but not DECK_KAMIGAWA_SUN. Of course it still shows [DECK_KAMIGAWA_SUN]. :wink:
< Former DotP 2012/2013/2014 modder >
Currently busy with life...
User avatar
thefiremind
Programmer
 
Posts: 3515
Joined: 07 Nov 2011, 10:55
Has thanked: 118 times
Been thanked: 717 times

Re: Deck won't appear

Postby Master Necro » 29 Apr 2013, 14:20

Well I did use the file at first and it didn't work so I tried to make one from sumomole mod and it didn't work either. :P

And thank you once again I will try that. :)

EDIT: WORKS!!! Uploading correct versions now! :)

Thank you! :)
User avatar
Master Necro
 
Posts: 259
Joined: 24 Apr 2013, 18:25
Has thanked: 83 times
Been thanked: 21 times


Return to Programming Talk

Who is online

Users browsing this forum: No registered users and 1 guest


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 10 minutes)
Most users ever online was 287 on 31 Mar 2019, 04:11

Users browsing this forum: No registered users and 1 guest

Login Form