It is currently 23 Sep 2018, 16:44
   
Text Size

AI Crashes if it plays one of my decks?

User-made mods in DLC (Downloadable Content) form.
Get MTG cards here for your DotP that aren't available anywhere else!

Moderators: Xander9009, CCGHQ Admins

AI Crashes if it plays one of my decks?

Postby BloodReyvyn » 28 May 2013, 23:05

I am very confused, after playing 10 consecutive games with one of my new decks, that the deck plays flawlessly when I am playing it but after another five attempts to play against the deck, the game crashes randomly every single game. Sometimes right at the beginning, other times after a long while and one of us is almost dead.

I get the usual windows error, "Magic: The Gathering: Duels of the Planeswalkers 2013 has stopped working and needs to close."

When I went to check the script and error logs, there were none and if I click the "Details" button on the windows error, it is completely blank. :|
"There's an experience worse than blindness - it's the certainty that your vision is perfect and the horror that there's no world around you to see."
User avatar
BloodReyvyn
 
Posts: 404
Joined: 19 May 2013, 13:29
Has thanked: 48 times
Been thanked: 38 times

Re: AI Crashes if it plays one of my decks?

Postby thefiremind » 28 May 2013, 23:10

If a deck crashes only when the AI is using it, it often means that you have a duplicate LAND_POOL ID, or to be precise, a LAND_POOL ID that is used also for something else that isn't a LAND_POOL. "Often" doesn't mean "always", but that should be the first thing to check. And it's also very easy to do now if you use RiiakShiNal's deck builder and look inside its log.

If you can't solve the problem this way, let me know which deck of yours causes the crash and I'll look into it.
< Former DotP 2012/2013/2014 modder >
Currently busy with life. Don't expect answers to PMs.
User avatar
thefiremind
Programmer
 
Posts: 3513
Joined: 07 Nov 2011, 10:55
Has thanked: 117 times
Been thanked: 715 times

Re: AI Crashes if it plays one of my decks?

Postby BloodReyvyn » 28 May 2013, 23:41

Cool, I found the issue. Probably the same issue that guy was having with my Heaven's Fury deck. Originally, I was going to change the land pool since it was the first deck I actually put together, but I scratched making the new lands and forgot to change the land .xml string variables back to default. So, it was looking for lands that didn't exist anymore.

Since I based two other decks off of that one, using it as a template of sorts, they all had screwed up land pools. Thanks, I would never have even looked at the names otherwise :oops:
"There's an experience worse than blindness - it's the certainty that your vision is perfect and the horror that there's no world around you to see."
User avatar
BloodReyvyn
 
Posts: 404
Joined: 19 May 2013, 13:29
Has thanked: 48 times
Been thanked: 38 times


Return to New MTG Cards and Decks

Who is online

Users browsing this forum: No registered users and 1 guest


Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 10 minutes)
Most users ever online was 279 on 11 Jul 2013, 22:03

Users browsing this forum: No registered users and 1 guest

Login Form