It is currently 14 Dec 2017, 22:45
   
Text Size

Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

by BetaSteward

Moderators: noxx, Aurum, fireshoes, jeffwadsworth, TheElk801, BetaSteward, LevelX, North, escplan9, CCGHQ Admins

Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby LevelX » 06 Nov 2016, 16:18

Please report here any problems/bugs you have while installing or updating XMage.

Best add information what exactly you do and exactly what error message or reaction of the system you get.

It's always a good thing to post also the error message from the xmage_launcher.log file in launcher directory, if any error is written to the log concerning the problem.

Known problems:

JAVA
Java gives the following error message:
Java :: EXCEPTION_ACCESS_VIOLATION (0xc0000005)
Look here: https://github.com/magefree/mage/issues/2424

Linux: XMage does not run with openJDK .

XMage Launcher
  • It's important to quit the XMage Client before updating. If you update, while the XMage Client (or local XMage Server) is active, the update will fail. The update runs, but at the end, the version is not updated.
  • If you have problems to update, restart your system and try to update again.
  • In case of a error message as you start the launcher do the following:
    1) Open a command window.
    2) Set the current directory to the directory the launcher jar file is located.
    3) To start the launcher enter:
    java -jar XMageLauncher-0.3.8.jar
    and push the enter key, that should start the launcher. (So you're fine).
    4) Otherwise report the error message you get in the command window
User avatar
LevelX
DEVELOPER
 
Posts: 1611
Joined: 08 Dec 2011, 15:08
Has thanked: 173 times
Been thanked: 348 times

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby tikipanda » 06 Nov 2016, 17:05

Even with nothing but the launcher open, when I click "Update," the update runs but the version isn't actually updated. How do I solve this?

LevelX: Restart your system before the update in case a lock is still set to an object.
Is a error message written to the xmage_launcher.log file in the launcher directory?
tikipanda
 
Posts: 3
Joined: 25 Jan 2016, 21:20
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby asergioam » 06 Nov 2016, 17:57

It says I have version 1.18 installed but when i open it, it says 1.17 and doesn't let me connect to the server

LevelX: Restart your system. Only start the launcher and try to force the update (click update button, and confirm yes).
asergioam
 
Posts: 6
Joined: 12 Jul 2016, 09:42
Has thanked: 1 time
Been thanked: 1 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby 2c2bt » 06 Nov 2016, 21:37

I ran updated several times. It never works.

Every time the update completes, it tells me there is a new version available. I run the update. It completes. It never updates. And it tells me there is a new version available. I do it again. It is the same result over and over. It just never updates.

It tells me I have version 1.4.17V0.

LevelX: I switched the order of the download servers. Maybe you have problems with one of the servers where the download is located. Try again after restarting your system and starting nothing else but the launcher.
2c2bt
 
Posts: 1
Joined: 06 Nov 2016, 21:35
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby Watsst » 08 Nov 2016, 09:17

Hi, I too am having a problem with it not updating.

I attempted the direct xmage download featured here:
viewtopic.php?f=70&t=19428

Unfortunately it says that the zip is incomplete/broken so i cant unload it.

LevelX: Also the second link has the same problem?
Watsst
 
Posts: 2
Joined: 20 Sep 2016, 08:24
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby Aximili » 11 Nov 2016, 12:09

Hi,

Having issues installing the launcher at all. I am on Windows 10 and I installed Java 1.8.0_111. I have downloaded the launcher installer from xmage . de and upon opening the .jar I get an erro rmessage saying "Unable to launch the application" and the following exception.

(attaching exception because of phpbb whinging that my post looks too "spammy for a new user")

Reinstalled Java, rebooted PC and redownloaded the launcher and I get the same error every time. Any help?

java error.txt
Java exception
(1.91 KiB) Downloaded 83 times



LevelX:
1) Open a command window.
2) Set the current directory to the directory the launcher jar file is located.
3) To start the launcher enter:
java -jar XMageLauncher-0.3.8.jar
and push the enter key, that should start the launcher. (So you're fine).
4) Otherwise report the error message you get in the command window
Aximili
 
Posts: 1
Joined: 11 Nov 2016, 11:53
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby JeskaiCharmer » 20 Nov 2016, 19:38

Having a Java issue. Ever since version 1.4.16, when I try to start the client I get a pop-up window telling me "A Java Exception occurred." http://imgur.com/anR28QK
I tried waiting a few versions to try again, but it's still not working with 1.4.18.

My Java is up to date. Any help is appreciated as I'm jonesing for xmage.


LevelX:
1) Open a command window.
2) Set the current directory to the directory the launcher jar file is located.
3) To start the launcher enter:
java -jar XMageLauncher-0.3.8.jar
and push the enter key, that should start the launcher. (So you're fine).
4) Otherwise report the error message you get in the command window
JeskaiCharmer
 
Posts: 68
Joined: 21 Oct 2014, 03:58
Has thanked: 2 times
Been thanked: 0 time

Re: Stuck on Installing xmage...

Postby Baldwin » 28 Nov 2016, 19:40

I am attempting to install xmage on a Mac using the latest Sierra OS and fully updated Java.

The installer gets through Java download and installation, then after downloading Xmage, I get:

Java version installed: 1.8.0_102
Java version available: 1.8.0_102
XMage version installed:
XMage version available: 1.4.19V0 (2016-11-27)
XMage not found
Installing XMage...

And then, it just sits there, no progress, for as long as I want to leave it open. I have tried restarting the computer, deleting all xmage files and reinstalling from a newly downloaded installer, and I keep getting the same result.

Help?
Baldwin
 
Posts: 1
Joined: 28 Nov 2016, 19:27
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby SpiderFerg » 29 Nov 2016, 00:48

I am having a similar problem. Xmage launcher says that an update is available. I click update. It finishes and says an update is available without actually having updated.

Also, when I try to launch either client or server, it gives me an error message that I will attach below.

I have tried restarting my computer and updating but the same problem happens. Thanks for helping with this.
Attachments
Screen Shot 2016-11-28 at 5.47.09 PM.png
SpiderFerg
 
Posts: 1
Joined: 29 Nov 2016, 00:42
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby MonkeyHouse » 30 Nov 2016, 01:58

:Solved:

I am having a problem downloading the new update.

When I try to download using the launcher by clicking "update" it gets about 1/4 done and pops up the window "New Version of Xmage Available" and I have to click the "update" button again to start the process all over with the same results.

When I try to download the zip file directly through chrome my download yet again stops about 1/4 through and says the download is complete. When I open the zip file it says the files are corrupt(Naturally because it didn't fully download)

I have tried restarting my computer. I have also deleted all xmage files and folders from my computer and starting from scratch.

Still having the same problem.

Must be a problem with the server because I can download very large files from other multiple sources without any problems.


:::EDIT::: Problem was solved clicking on the 2nd download link. Thanks!
MonkeyHouse
 
Posts: 1
Joined: 30 Nov 2016, 01:51
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby CRASHxtrm » 26 Dec 2016, 21:22

Hi,

I have encountered a problem recently. While i never had any problems launching Xmage neither changed anything,
i now get this message whenever i try to launch the client: "Error: could not open `C:\Users\CRASHxtrm\Downloads\java\jre1.8.0_102\lib\amd64\jvm.cfg' "

I tried uninstalling and installing Java back, but nothing changed. Any suggestions/solutions?

Thanks in advance.
CRASHxtrm
 
Posts: 3
Joined: 26 Dec 2016, 21:20
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby xxSkedz24xx » 27 Dec 2016, 22:11

Hi, before today I have never had any issues with the launcher, but today when I tried to launch the client, I got the string of messages pasted below:

org.h2.jdbc.JdbcSQLException: General error: "java.lang.IllegalStateException: File corrupted in chunk 31181, expected page length =< 256, got 1095914569 [1.4.187/6]" [50000-187]
at org.h2.message.DbException.getJdbcSQLException(DbException.java:345)
at org.h2.message.DbException.get(DbException.java:168)
at org.h2.message.DbException.convert(DbException.java:295)
at org.h2.engine.Database.openDatabase(Database.java:297)
at org.h2.engine.Database.<init>(Database.java:260)
at org.h2.engine.Engine.openSession(Engine.java:60)
at org.h2.engine.Engine.openSession(Engine.java:167)
at org.h2.engine.Engine.createSessionAndValidate(Engine.java:145)
at org.h2.engine.Engine.createSession(Engine.java:128)
at org.h2.engine.Engine.createSession(Engine.java:26)
at org.h2.engine.SessionRemote.connectEmbeddedOrServer(SessionRemote.java:347)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:108)
at org.h2.jdbc.JdbcConnection.<init>(JdbcConnection.java:92)
at org.h2.Driver.connect(Driver.java:72)
at java.sql.DriverManager.getConnection(DriverManager.java:664)
at java.sql.DriverManager.getConnection(DriverManager.java:208)
at com.j256.ormlite.jdbc.JdbcConnectionSource.makeConnection(JdbcConnectionSource.java:252)
at com.j256.ormlite.jdbc.JdbcConnectionSource.getReadWriteConnection(JdbcConnectionSource.java:184)
at com.j256.ormlite.table.TableUtils.doCreateTable(TableUtils.java:440)
at com.j256.ormlite.table.TableUtils.createTable(TableUtils.java:220)
at com.j256.ormlite.table.TableUtils.createTableIfNotExists(TableUtils.java:61)
at mage.cards.repository.RepositoryUtil.isDatabaseObsolete(RepositoryUtil.java:20)
at mage.cards.repository.ExpansionRepository.<init>(ExpansionRepository.java:42)
at mage.cards.repository.ExpansionRepository.<clinit>(ExpansionRepository.java:24)
at org.mage.card.arcane.ManaSymbols.loadImages(ManaSymbols.java:53)
at mage.client.MageFrame.<init>(MageFrame.java:289)
at mage.client.MageFrame$20.run(MageFrame.java:1286)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.IllegalStateException: File corrupted in chunk 31181, expected page length =< 256, got 1095914569 [1.4.187/6]
at org.h2.mvstore.DataUtils.newIllegalStateException(DataUtils.java:773)
at org.h2.mvstore.Page.read(Page.java:642)
at org.h2.mvstore.Page.read(Page.java:196)
at org.h2.mvstore.MVStore.readPage(MVStore.java:1843)
at org.h2.mvstore.MVMap.readPage(MVMap.java:736)
at org.h2.mvstore.MVMap.setRootPos(MVMap.java:746)
at org.h2.mvstore.MVStore.openMap(MVStore.java:466)
at org.h2.mvstore.db.TransactionStore.openMap(TransactionStore.java:389)
at org.h2.mvstore.db.TransactionStore$Transaction.openMap(TransactionStore.java:743)
at org.h2.mvstore.db.MVSecondaryIndex.<init>(MVSecondaryIndex.java:72)
at org.h2.mvstore.db.MVTable.addIndex(MVTable.java:437)
at org.h2.command.ddl.CreateIndex.update(CreateIndex.java:94)
at org.h2.engine.MetaRecord.execute(MetaRecord.java:58)
at org.h2.engine.Database.open(Database.java:735)
at org.h2.engine.Database.openDatabase(Database.java:266)
... 37 more
FATAL 2016-12-27 17:09:14,014 MAGE Client UI error =>[AWT-EventQueue-0] EDTExceptionHandler.handle
java.lang.NullPointerException
at mage.cards.repository.ExpansionRepository.getSetCodes(ExpansionRepository.java:65)
at org.mage.card.arcane.ManaSymbols.loadImages(ManaSymbols.java:53)
at mage.client.MageFrame.<init>(MageFrame.java:289)
at mage.client.MageFrame$20.run(MageFrame.java:1286)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

How do I fix this?

EDIT: I was able to fix it by force updating Java
xxSkedz24xx
 
Posts: 33
Joined: 08 Jan 2015, 02:58
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby CRASHxtrm » 02 Jan 2017, 10:59

CRASHxtrm wrote:Hi,

I have encountered a problem recently. While i never had any problems launching Xmage neither changed anything,
i now get this message whenever i try to launch the client: "Error: could not open `C:\Users\CRASHxtrm\Downloads\java\jre1.8.0_102\lib\amd64\jvm.cfg' "

I tried uninstalling and installing Java back, but nothing changed. Any suggestions/solutions?

Thanks in advance.
Hello guys,

I really need a solution here!
CRASHxtrm
 
Posts: 3
Joined: 26 Dec 2016, 21:20
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby CRASHxtrm » 04 Jan 2017, 17:10

Aside my initial problem, now i downloaded the launcher again and it doesn't even run....what's going on?
CRASHxtrm
 
Posts: 3
Joined: 26 Dec 2016, 21:20
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby Dynamo345 » 08 Jan 2017, 20:32

its taking forever for the launcher to turn on for a glitch and i thought it was a automatic update thing is what causing this

if it is TURN IT OFF
Dynamo345
 
Posts: 116
Joined: 25 Apr 2016, 23:24
Has thanked: 3 times
Been thanked: 3 times

Next

Return to XMage

Who is online

Users browsing this forum: No registered users and 7 guests


Who is online

In total there are 7 users online :: 0 registered, 0 hidden and 7 guests (based on users active over the past 10 minutes)
Most users ever online was 279 on 11 Jul 2013, 22:03

Users browsing this forum: No registered users and 7 guests

Login Form