It is currently 17 Dec 2017, 09:48
   
Text Size

Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

by BetaSteward

Moderators: noxx, Aurum, fireshoes, jeffwadsworth, TheElk801, BetaSteward, LevelX, North, escplan9, CCGHQ Admins

Re: Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby HappyWaffle » 16 Jun 2017, 19:40

I haven't played the game in a while and today I decided to load it up and play for a bit but this is the error I get in the Client console.

I've updated Java to the latest version. I completely re-installed xmage. Same error every time.
Im on Windows 10 64-bit.

Jun 16, 2017 2:37:05 PM java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
INFO 2017-06-16 14:37:05,097 Starting MAGE client version 1.4.23V6 =>[main] MageFrame.main
INFO 2017-06-16 14:37:05,099 Logging level: INFO =>[main] MageFrame.main
#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ff8264afd0c, pid=15348, tid=0x0000000000001950
#
# JRE version: Java(TM) SE Runtime Environment (8.0_131-b11) (build 1.8.0_131-b11)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.131-b11 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C [d3d9.dll+0xfd0c]
#
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
#
# An error report file with more information is saved as:
# D:\Games\Xmage\xmage\mage-client\hs_err_pid15348.log
#
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=384m; support was removed in 8.0



LevelX: Please test this:
Especially with Windows 7, the JVM has not by default the permission to write into the Windows registry where the backing store for java.util.prefs.preferences is located under MS-Windows.
When executing xmage or xmagelauncher one can get errors like: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx
Fixing the issue is simply a matter of granting the necessary permissions to the registry root key at stake.
Run regedit.exe as administrator (regedit.exe is located in the c:\Windows operating system root directory).
Go to key HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Prefs.
Right click to set permissions. Check a mark in the Full Control check box for the user(s) that need executing the xmage software.
Please give feedback if it helps.
HappyWaffle
 
Posts: 2
Joined: 16 Jun 2017, 19:26
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby HappyWaffle » 17 Jun 2017, 19:19

^This did not work. I did, however, figure out the problem. I get this error only when MSI Afterburner is running. If I close Afterburner, xmage runs perfectly. I am having this issue on all 3 of my computers. It's not really a big deal but I definitely didn't have this problem when I last played xmage about 4 months ago.
HappyWaffle
 
Posts: 2
Joined: 16 Jun 2017, 19:26
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.24 SOFTWARE

Postby tself55 » 09 Jul 2017, 20:18

On Mac, the Java launcher refuses to download 1.4.24v2
tself55
 
Posts: 41
Joined: 16 Feb 2015, 19:49
Has thanked: 0 time
Been thanked: 3 times

Re: Bug Reports XMage 1.4.24 SOFTWARE

Postby jasonpitts » 09 Jul 2017, 20:28

I am having a problem where I am up updating the current version. The bar gets almost done, and then everything quits, and it says new version detected. I've done this several times, and it never completes the upload. Can anyone help?
jasonpitts
 
Posts: 1
Joined: 09 Jul 2017, 20:25
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.24 SOFTWARE

Postby NittanyLionRoar » 09 Jul 2017, 20:43

jasonpitts wrote:I am having a problem where I am up updating the current version. The bar gets almost done, and then everything quits, and it says new version detected. I've done this several times, and it never completes the upload. Can anyone help?
I am having the same problem on Mac. I see that someone else is too.
NittanyLionRoar
 
Posts: 6
Joined: 30 Jan 2016, 15:12
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby Tris13 » 09 Jul 2017, 21:04

On a Mac and I cant download update 1.4.24V2
I hit download, the bar loads halfway and then I get the "A newer version of Xmage is available" pop up again
I have already restarted my computer and tried again

Update: it finally downloaded
Last edited by Tris13 on 10 Jul 2017, 04:07, edited 1 time in total.
Tris13
 
Posts: 3
Joined: 09 Jul 2017, 21:01
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.24 SOFTWARE

Postby kai » 09 Jul 2017, 21:12

NittanyLionRoar wrote:
jasonpitts wrote:I am having a problem where I am up updating the current version. The bar gets almost done, and then everything quits, and it says new version detected. I've done this several times, and it never completes the upload. Can anyone help?
I am having the same problem on Mac. I see that someone else is too.
Same problem here. If anyone finds a fix let me know with a reply. I am itching to try this new set. When I download directly from bit ly /xmage_1_4_24V2o the file stops short at around 50 mb out of 126 mb. All previous versions (V0o, V1o, etc.) are doing similar things. Seems to be a problem beyond heavy traffic but I am no expert.
kai
 
Posts: 1
Joined: 09 Jul 2017, 20:59
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.24 SOFTWARE

Postby bravelion83 » 09 Jul 2017, 22:24

tself55 wrote:On Mac, the Java launcher refuses to download 1.4.24v2
I have the same problem on Windows 7. The launcher tells me there is a new version, I hit "update", all buttons deactivates, but the advancement bar is stuck and does not advance. It looks like it doesn't download anything at all and I can't do anything else but close the launcher window. I see others aren't able to download the update, but I just wanted to point out that it's not a problem exclusive to Mac users.
bravelion83
 
Posts: 2
Joined: 09 Jul 2017, 22:15
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby Provo » 18 Jul 2017, 11:35

Hi,

I was eager to try out your work but I seem to be quite unlucky. I have downloaded the 'newest' version from XMage homepage by clicking "Download XMage-Launcher" and it downloads the 0.3.8 version which was a surprise to me but later I discovered that it's only the launcher. Anyway, I installed java as well, from this Java homepage and I thought it's gonna be only easier from that point... BUT NO.

The .jar launcher file does not want to open with any java related shit. When I unpack it, there is no .exe or .bat files in any subfolders of this package. When I try to "open with" it using "Java TM Platform SE Binary" a command window pops and goes like it never existed and that's it. I restarted, reinstalled and performed literally MAGIC on my computer and nothing seems to work.

Probably the problem is more simple than I thought but it's just so frustrating.

I would be deeply grateful for any help in that matter.
Provo
 
Posts: 1
Joined: 18 Jul 2017, 11:23
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby mulumbo » 24 Jul 2017, 18:04

I am having so many issues since the 1.4.24V3 update.

These are my problems from today (07/24/2017).

Launcher has downloaded Java and Xmage about three times.

When I attempt to join a table, the client freezes with the "OK" button depressed.

If I try to start my own table, I will sometimes get a window for the table, sometimes not. When I do, I see in the text screen that someone has joined, but they never appear in the table so I can press start.

Yesterday's problems (07/23/2017)

Cracked an evolving wilds, pressed done (once), library did not appear and it said I was waiting on my opponent. Opponent said it was waiting on me. There were no buttons that popped up.

It froze many times during games. I never got through one game without something requiring me to quit the game entirely.

SYSTEM INFO: Windows 10 Home 64 bit; Java Version 8 (141); Xmage 1.4.24V3
mulumbo
 
Posts: 1
Joined: 24 Jul 2017, 17:47
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.1.18 INSTALLING / LAUNCHER / JAVA

Postby madstyx » 24 Jul 2017, 21:52

JeskaiCharmer wrote:Having a Java issue. Ever since version 1.4.16, when I try to start the client I get a pop-up window telling me "A Java Exception occurred." http://imgur.com/anR28QK
I tried waiting a few versions to try again, but it's still not working with 1.4.18.

My Java is up to date. Any help is appreciated as I'm jonesing for xmage.


LevelX:
1) Open a command window.
2) Set the current directory to the directory the launcher jar file is located.
3) To start the launcher enter:
java -jar XMageLauncher-0.3.8.jar
and push the enter key, that should start the launcher. (So you're fine).
4) Otherwise report the error message you get in the command window
I too, have been having the same problem, and while this fix works--launching the launcher via the command prompt--is there any permanent fix to this issue?
madstyx
 
Posts: 6
Joined: 17 Nov 2014, 04:42
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby Itachi8531 » 03 Aug 2017, 02:04

I have updated to the newest version (v. 1.4.25VO) but my client still launches 1.4.24V3 so I can't log in even.
Itachi8531
 
Posts: 1
Joined: 03 Aug 2017, 02:00
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby Dynamo345 » 15 Aug 2017, 00:37

well its simple.

the launcher is not finding version 1.4.26 update

the commander 2017 set

(although everything but the eminence commanders might not be in it.)
Dynamo345
 
Posts: 116
Joined: 25 Apr 2016, 23:24
Has thanked: 3 times
Been thanked: 3 times

Re: Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby Faavre » 18 Aug 2017, 05:31

Wow I've been using Xmage without the launcher and this fixed it:

1) Open a command window.
2) Set the current directory to the directory the launcher jar file is located.
Type cd followed by a space. Type in the directory name.
3) To start the launcher enter:
java -jar XMageLauncher-0.3.8.jar
and push the enter key, that should start the launcher. (So you're fine).

Thanks LevelX

Correction. I still can't start the launcher without the CMD prompt now. I just want to double-click the link. I switched the "open with" command to javaw (in the xmage java bin folder) and dried the PC's javaw too. I'm still stuck.

There is no error message. It just does nothing when I click the link.
Faavre
 
Posts: 16
Joined: 20 Aug 2014, 20:24
Has thanked: 20 times
Been thanked: 2 times

Re: Bug Reports XMage 1.4.xx INSTALLING / LAUNCHER / JAVA

Postby Zakading » 16 Sep 2017, 21:12

Tried updating to 1.4.26V4 twice now and both times it stopped progress at around 80% with nothing happening from that point on. Have been waiting for 2 hours to no avail.

It can't be an issue with my connection, as it is stable and updated to that point without much problem, nor should it be any firewall problem.
Zakading
 
Posts: 8
Joined: 23 Mar 2016, 15:45
Has thanked: 0 time
Been thanked: 0 time

PreviousNext

Return to XMage

Who is online

Users browsing this forum: No registered users and 7 guests

cron

Who is online

In total there are 7 users online :: 0 registered, 0 hidden and 7 guests (based on users active over the past 10 minutes)
Most users ever online was 279 on 11 Jul 2013, 22:03

Users browsing this forum: No registered users and 7 guests

Login Form