It is currently 14 Aug 2018, 18:00
   
Text Size

Ubuntu 16.04 fatal error after update to 1.4.27v1

by BetaSteward

Moderators: LevelX, BetaSteward, North, escplan9, noxx, Aurum, fireshoes, jeffwadsworth, TheElk801, CCGHQ Admins

Ubuntu 16.04 fatal error after update to 1.4.27v1

Postby karpidis » 29 Jan 2018, 04:33

I paste the error when I try to launch client.
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=384m; support was removed in 8.0
INFO 2018-01-29 06:29:09,545 Starting MAGE client version 1.4.27V1 =>[main] MageFrame.main
INFO 2018-01-29 06:29:09,550 Logging level: INFO =>[main] MageFrame.main
FATAL 2018-01-29 06:29:12,707 MAGE Client UI error =>[AWT-EventQueue-0] EDTExceptionHandler.handle
java.lang.VerifyError: (class: org/apache/batik/bridge/BridgeContext, method: dispose signature: ()V) Incompatible object argument for function call
at org.apache.batik.transcoder.SVGAbstractTranscoder.transcode(SVGAbstractTranscoder.java:150)
at org.apache.batik.transcoder.image.ImageTranscoder.transcode(ImageTranscoder.java:86)
at org.apache.batik.transcoder.XMLAbstractTranscoder.transcode(XMLAbstractTranscoder.java:132)
at org.mage.card.arcane.ManaSymbols.loadSVG(ManaSymbols.java:293)
at org.mage.card.arcane.ManaSymbols.loadSymbolAsSVG(ManaSymbols.java:361)
at org.mage.card.arcane.ManaSymbols.loadSymbolImages(ManaSymbols.java:429)
at org.mage.card.arcane.ManaSymbols.loadImages(ManaSymbols.java:89)
at mage.client.MageFrame.<init>(MageFrame.java:226)
at mage.client.MageFrame.lambda$main$16(MageFrame.java:1179)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Until yesterday it worked
karpidis
 
Posts: 4
Joined: 29 Jan 2018, 04:14
Has thanked: 0 time
Been thanked: 0 time

Re: Ubuntu 16.04 fatal error after update to 1.4.27v1

Postby JayDi » 29 Jan 2018, 06:03

It's a weird x64 linux machines error. Working on it (you can monitor here on github).

As workaround -- find xmage images folder and delete "svg" folder from it. Restart app and do not download symbols by menu (or download it but delete svg folder again).
User avatar
JayDi
 
Posts: 47
Joined: 23 Nov 2017, 15:41
Location: Russia
Has thanked: 0 time
Been thanked: 9 times


Return to XMage

Who is online

Users browsing this forum: No registered users and 7 guests


Who is online

In total there are 7 users online :: 0 registered, 0 hidden and 7 guests (based on users active over the past 10 minutes)
Most users ever online was 279 on 11 Jul 2013, 22:03

Users browsing this forum: No registered users and 7 guests

Login Form