Page 1 of 1

Shandalar used to work great, now crashes

PostPosted: 13 Aug 2011, 16:14
by Haytrid
I have installed only the official "Microprose Magic the Gathering 2010 Custom Installer ISO" and only the "CCGHQ Microprose DOTP Custom ISO Update". I only play and only am interested in playing Shandalar and nothing else.

I had it installed and was playing it for a year or more and never had any problems, went to play it today and boom, error trying to start "Shandalar.exe" and when I try to run "MTGLauncher.exe" nothing happens but no error message. All other executable files work fine and I even played through a sealed deck tournament.

The error is:

"Magic:The Gathering Duel has stopped working" immediately after trying to launch.

I tried to uninstall and reinstall from scratch and messed with the compatibility settings again, no luck.

The computer is in it's original state from when it worked except the usual windows and video card updates, which I'm guessing one of which such updates may have broke it?

I'm running registered Windows 7 Ultimate 64 bit edition.

Any help would be greatly appreciated, I really love this game.


Re: Shandalar used to work great, now crashes

PostPosted: 13 Aug 2011, 23:47
by Sonic
We have recently received some very useful information from a Win7 64-bit users, which you might like to try.

CarlPH wrote:
llk2k6 wrote:Hello, I'm using Windows 7 64-bit installing to the default directory (C:\Program Files (x86)\MagicTG) and I can't launch the launcher or Shandalar yet everything else works fine. Anyone else run into this problem and if so how do I fix it?
I was running Windows 7 64-bit home and had this same problem. Everything works fine except the launcher and shandalar. And luckily I found the fix just yesterday.

The trick is, to include MTGlauncher.exe and Shandalar.exe as exceptions to Window 7's Data Execution Prevention(DEP).

Note: You must have administrator access to do this

Go to My computer > Right click it and click Properties
At the left part of your window click > remote setttings
Click the Advanced Tab
Under Performance > Click Settings (the uppermost most button)
Now Click the Data Execution Prevention (DEP) tab
o Turn on DEP for all programs and services except those I select

click add, and browse your MagicTG Folder(Game installation folder) and select MTGlauncher.exe

click add again then select Shandalar.exe

I tested this myself and shandalar should now work fine on your Windows 7 system

Re: Shandalar used to work great, now crashes

PostPosted: 14 Aug 2011, 13:20
by Haytrid
Wooow, thank you sooo much.

Disabling DEP worked!

I only vaguely remember using that DEP at work and have never used it on my home computer. One of the windows updates or recently installed programs must have enabled it I'm thinking but that was definitely the solution! I'm back up and running on Shandalar!

Thank you again and I very much appreciate the assistance!

Re: Shandalar used to work great, now crashes

PostPosted: 14 Aug 2011, 15:42
by Sonic
Don't thank me, thank CarlPH. I'm just surprised, considering the number of people known to be using Win7 64, that nobody has found this solution earlier.


Re: Shandalar used to work great, now crashes

PostPosted: 14 Feb 2012, 08:15
by Geewhizbatman
Hey there--

So, I downloaded the game using the ISO torrent that linked to this forum. I then downloaded and copied the update. I had a lot of trouble getting it to work but the DEP fix worked to get it running, which is great.

However, now none of the text shows up. I'm not sure if this is a color scheme issue or compatibility or what. Anyone have any idea what I should do?

Re: Shandalar used to work great, now crashes

PostPosted: 15 Feb 2012, 21:54
by Huggybaby

Re: Shandalar used to work great, now crashes

PostPosted: 15 May 2016, 20:29
by bolav
Hi. I'm new to all this. But this fix does not work for windows 10. I installed a fresh installation with the instructions I found here
I've installed nothing else. Although I have downloaded a lot of zips from you guys I have them all just in case. All I want is to play Shandalar. Any help would be welcome. (I'm not a programmer... so it has been a wild two days sorting out this forum, but great job at keeping this program alive. It's still the best out there.)

Re: Shandalar used to work great, now crashes

PostPosted: 15 May 2016, 21:52
by bolav
I fixed my shandalar and it's working now. I used this;
I noticed that after using this full package install, I had 2 shandalar.exe.
1. Shandalar.exe which was the one installed and
2. _Shandalar.exe which was the one in the full package.
Since the one installed didn't work I left #2. Is that ok?
Having done this full package install can I install more cards? And if so which?
I'm a newb in this so I really am sorry if this is a repetitive newb problem.
I haven't played any new cards in years and seeing Shandalar with all those new cards almost made me weep. Amazing job!

Re: Shandalar used to work great, now crashes

PostPosted: 18 May 2016, 20:04
by bolav
For those who have this problem but can't use the fix above with windows 10. There is a solution;

1. run command prompt with admin privileges
2. Copy/paste the following line to command prompt:
bcdedit.exe /set {current} nx OptOut
3. Restart
4. Follow the steps above or
That's it.

Re: Shandalar used to work great, now crashes

PostPosted: 10 Jan 2018, 23:44
by guyfromcroswell
Obviously it's been awhile since someone posted here. My current setup is Windows 7 64Bit Ultimate, and I am updated to the final (sadly) Eldritch Moon v2 patch.

I have several issues. Originally I couldn't get Shandalar to run, but after the DEP fix it started just fine. When I start a new game, I get to color selection and no matter what I click on it won't move forward. When I load a game it seems to work but if I try to buy cards or enter one of the caves that appear it will crash with this error.

Problem signature:
Problem Event Name: APPCRASH
Application Name: Shandalar.exe
Application Version:
Application Timestamp: 3517e16d
Fault Module Name: DrawCardLib.dll
Fault Module Version:
Fault Module Timestamp: 57c07870
Exception Code: c0000005
Exception Offset: 000067d6
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

It also have an issue with the insanely crappy resolution which I'm not sure if I can fix. If I try to use the edit deck/sell cards function it looks like this. Any help would be appreciated.

Edit Deck/Sell Cards

I love this game and I can't thank everyone enough for home much I enjoy playing it with updated cards. I play it everyday since I discovered it.