It is currently 17 Apr 2021, 07:37
   
Text Size

The SVN, nightly builds and biweekly betas

Post MTG Forge Related Programming Questions Here

Moderators: timmermac, friarsol, Blacksmith, KrazyTheFox, Agetian, CCGHQ Admins

Re: The SVN, nightly builds and biweekly betas

Postby Corwin72 » 09 Jul 2012, 12:14

Did anyone else have issues downloading the new m13 set images this weekend. They were showing up as corrupt for me.
User avatar
Corwin72
 
Posts: 793
Joined: 15 Sep 2009, 13:26
Location: Grayson, Ga
Has thanked: 25 times
Been thanked: 9 times

Re: The SVN, nightly builds and biweekly betas

Postby friarsol » 09 Jul 2012, 13:52

Corwin72 wrote:Did anyone else have issues downloading the new m13 set images this weekend. They were showing up as corrupt for me.
No set images are available for M13 yet.
friarsol
Global Moderator
 
Posts: 7566
Joined: 15 May 2010, 04:20
Has thanked: 242 times
Been thanked: 954 times

Re: The SVN, nightly builds and biweekly betas

Postby PowerClaws » 10 Jul 2012, 15:03

friarsol wrote:
Corwin72 wrote:Did anyone else have issues downloading the new m13 set images this weekend. They were showing up as corrupt for me.
No set images are available for M13 yet.
Is this the same for planeschase 2012, i cant download correct images for these yet either
PowerClaws
 
Posts: 131
Joined: 30 Jan 2012, 11:33
Has thanked: 28 times
Been thanked: 8 times

Re: The SVN, nightly builds and biweekly betas

Postby moomarc » 10 Jul 2012, 15:13

PowerClaws wrote:
friarsol wrote:
Corwin72 wrote:Did anyone else have issues downloading the new m13 set images this weekend. They were showing up as corrupt for me.
No set images are available for M13 yet.
Is this the same for planeschase 2012, i cant download correct images for these yet either
That's correct. You can check out the Pictures forum from the main board to see when they finish the scans. We'll have them ready for Forge soon after.
-Marc
User avatar
moomarc
Pixel Commander
 
Posts: 2091
Joined: 04 Jun 2010, 15:22
Location: Johannesburg, South Africa
Has thanked: 371 times
Been thanked: 371 times

Re: The SVN, nightly builds and biweekly betas

Postby Chris H. » 11 Jul 2012, 12:50

Rares has ended his involvement with his blog site and that site has a link to version 1.2.6 and this link is not likely to be updated in the future. We should expect that people who make the transition to SlightlyMagic will have an out of date version installed.

Marc pointed out that some of the people might transition over to the cardforge blog/site looking for a newer version.

Rob added a blog to cardforge and posted messages about the newest beta release for a few versions. He requested that I take over this responsibility and I did my best for a few versions.

A couple of releases ago I noticed that I could no longer sign in to the cardforge site. I have decided that having an active blog on cardforge may be unnecessary. I think that Rob and I would rather spend our limited free time on other areas of the forge project. :)

Rob might want to consider one last post stating that people should meet us at the SlightlyMagic Forge topic for links and good conversation. :)
User avatar
Chris H.
Forge Moderator
 
Posts: 6320
Joined: 04 Nov 2008, 12:11
Location: Mac OS X Yosemite
Has thanked: 644 times
Been thanked: 643 times

Re: The SVN, nightly builds and biweekly betas

Postby Chris H. » 13 Jul 2012, 11:34

Chris H. wrote:I noticed that people are referring to our snapshot builds on the Bug Reports (snapshot builds) topic by only using the SVN rev number that is found in the title bar.

This number is now always stuck on the number "r15897" even though we passed that number some time ago. I think that we need to find a way to remove this data from the title bar as it is misleading people.

I added a simple fix today that will remove the string "-r15897". I plan to add it to the SVN. My fix will not remove other SVN rev numbers. If Dave decides to release a few snapshots while I am offline while moving then the correct SVN rev number will be displayed in the title bar.
 
 
The incorrect number that is displayed appears to increase at some point in time. #-o

A couple of days ago the number increased to 16084.
User avatar
Chris H.
Forge Moderator
 
Posts: 6320
Joined: 04 Nov 2008, 12:11
Location: Mac OS X Yosemite
Has thanked: 644 times
Been thanked: 643 times

Re: The SVN, nightly builds and biweekly betas

Postby Chris H. » 14 Jul 2012, 12:47

Chris H. wrote:
Chris H. wrote:I noticed that people are referring to our snapshot builds on the Bug Reports (snapshot builds) topic by only using the SVN rev number that is found in the title bar.

This number is now always stuck on the number "r15897" even though we passed that number some time ago. I think that we need to find a way to remove this data from the title bar as it is misleading people.

I added a simple fix today that will remove the string "-r15897". I plan to add it to the SVN. My fix will not remove other SVN rev numbers. If Dave decides to release a few snapshots while I am offline while moving then the correct SVN rev number will be displayed in the title bar.
 
 
The incorrect number that is displayed appears to increase at some point in time. #-o

A couple of days ago the number increased to 16084.
 
Several weeks ago I added in a test that checked the build info string to see if it contained "r15897". And if it did it was replaced with "". For a couple of weeks we had version 1.2.10 snapshot builds that did not include the out of date SVN rev number.

Two days before the 1.2.10 beta release I noticed that the snapshot build was now displaying a new number, "r16084". I attempted to modify my code addition to remove this new number before the beta release.

I unfortunately made a mistake and the beta displays the "r16084" on my copy of the 1.2.10 beta release.

A person posted a crash report on the 1.2.10 beta release topic. His crash report does not state "r16084" but instead gives the correct SVN rev number "r16193".

Re: Forge Beta: 07-13-2012 ver 1.2.10
User avatar
Chris H.
Forge Moderator
 
Posts: 6320
Joined: 04 Nov 2008, 12:11
Location: Mac OS X Yosemite
Has thanked: 644 times
Been thanked: 643 times

Re: The SVN, nightly builds and biweekly betas

Postby Chris H. » 01 Aug 2012, 11:02

My attempt to do a snapshot build and release today failed.

The Maven command that I use needs to have all of the tests succeed and one of them is failing. I assume that this may be related to rev 16394 as it's commit log mentions that the test no longer is functional.

Looks like an effort was made in rev 16396 to fix this but it did not help.
User avatar
Chris H.
Forge Moderator
 
Posts: 6320
Joined: 04 Nov 2008, 12:11
Location: Mac OS X Yosemite
Has thanked: 644 times
Been thanked: 643 times

Re: The SVN, nightly builds and biweekly betas

Postby Chris H. » 01 Aug 2012, 19:44

I disabled the DeckWantsTest.testNoFilter() test and the Maven build and release commands will once again work. This is not a true fix but just a hack in order to do a Maven build and release.
User avatar
Chris H.
Forge Moderator
 
Posts: 6320
Joined: 04 Nov 2008, 12:11
Location: Mac OS X Yosemite
Has thanked: 644 times
Been thanked: 643 times

Re: The SVN, nightly builds and biweekly betas

Postby Nordos » 23 Aug 2012, 19:16

A bug I noticed in the 8. snapshot build (1.2.12): the description of Deadapult says that it deals one damage to target creature/player
Nordos
 
Posts: 558
Joined: 23 May 2011, 14:06
Has thanked: 6 times
Been thanked: 18 times

Re: The SVN, nightly builds and biweekly betas

Postby friarsol » 23 Aug 2012, 19:26

Nordos wrote:A bug I noticed in the 8. snapshot build (1.2.12): the description of Deadapult says that it deals one damage to target creature/player
Hey Nordos, please put bug reports for snapshot builds in this thread: viewtopic.php?f=52&t=6333
friarsol
Global Moderator
 
Posts: 7566
Joined: 15 May 2010, 04:20
Has thanked: 242 times
Been thanked: 954 times

Re: The SVN, nightly builds and biweekly betas

Postby Chris H. » 25 Aug 2012, 10:34

Tried to do a snapshot build and release today but it appears that one of the tests is failing.

Code: Select all
-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Running TestSuite
Configuring TestNG with: org.apache.maven.surefire.testng.conf.TestNGMapConfigurator@79dfc547
[white, red, blue]
failed : 0.9
failed : 0.91
failed : 38.0
failed : 41.0
failed : 42.0
failed : 43.0
ManaCost : addMana() error, mana not needed - 1
failed : 45.1
2
failed : 46.1
2
Tests run: 9, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 2.035 sec <<< FAILURE!

Results :

Failed tests:   testColor(forge.item.DeckHintsTest)

Tests run: 9, Failures: 1, Errors: 0, Skipped: 0

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 23.679s
[INFO] Finished at: Sat Aug 25 06:27:53 EDT 2012
[INFO] Final Memory: 17M/114M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.12:test (default-test) on project forge: There are test failures.
[ERROR]
[ERROR] Please refer to /Users/chrish/Workspace_SVN/ForgeSVN/target/surefire-reports for the individual test results.
[ERROR] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
logout
User avatar
Chris H.
Forge Moderator
 
Posts: 6320
Joined: 04 Nov 2008, 12:11
Location: Mac OS X Yosemite
Has thanked: 644 times
Been thanked: 643 times

Re: The SVN, nightly builds and biweekly betas

Postby mcrawford620 » 26 Aug 2012, 05:02

Chris H. wrote:Tried to do a snapshot build and release today but it appears that one of the tests is failing.
Fixed it.
mcrawford620
 
Posts: 112
Joined: 25 Jun 2012, 16:59
Has thanked: 55 times
Been thanked: 25 times

Re: The SVN, nightly builds and biweekly betas

Postby Chris H. » 26 Aug 2012, 10:23

mcrawford620 wrote:
Chris H. wrote:Tried to do a snapshot build and release today but it appears that one of the tests is failing.
Fixed it.
 
Thank you mcrawford. :D
User avatar
Chris H.
Forge Moderator
 
Posts: 6320
Joined: 04 Nov 2008, 12:11
Location: Mac OS X Yosemite
Has thanked: 644 times
Been thanked: 643 times

Re: The SVN, nightly builds and biweekly betas

Postby Chris H. » 24 Oct 2012, 11:47

Today's snapshot build attempt ended in an error.

Code: Select all
[INFO] Executed tasks
[INFO]
[INFO] --- build-helper-maven-plugin:1.7:attach-artifact (attach-distribution) @ forge ---
[WARNING] Artifact forge:forge:tar.bz2:1.2.16-SNAPSHOT already attached to project, ignoring duplicate
[INFO]
[INFO] --- build-helper-maven-plugin:1.7:attach-artifact (attach-distribution-osx) @ forge ---
[WARNING] Artifact forge:forge:tar.bz2:osx:1.2.16-SNAPSHOT already attached to project, ignoring duplicate
[INFO]
[INFO] --- maven-install-plugin:2.3.1:install (default-install) @ forge ---
[INFO] Installing /Users/chrish/Workspace_SVN/ForgeSVN/target/forge-1.2.16-SNAPSHOT.jar to /Users/chrish/.m2/repository/forge/forge/1.2.16-SNAPSHOT/forge-1.2.16-SNAPSHOT.jar
[INFO] Installing /Users/chrish/Workspace_SVN/ForgeSVN/pom.xml to /Users/chrish/.m2/repository/forge/forge/1.2.16-SNAPSHOT/forge-1.2.16-SNAPSHOT.pom
[INFO] Installing /Users/chrish/Workspace_SVN/ForgeSVN/target/forge-1.2.16-SNAPSHOT.tar.bz2 to /Users/chrish/.m2/repository/forge/forge/1.2.16-SNAPSHOT/forge-1.2.16-SNAPSHOT.tar.bz2
[INFO] Installing /Users/chrish/Workspace_SVN/ForgeSVN/target/forge-1.2.16-SNAPSHOT-osx.tar.bz2 to /Users/chrish/.m2/repository/forge/forge/1.2.16-SNAPSHOT/forge-1.2.16-SNAPSHOT-osx.tar.bz2
[INFO]
[INFO] --- maven-deploy-plugin:2.7:deploy (default-deploy) @ forge ---
Downloading: ftp.cardforge.org/snapshots/forge/forge/1.2.16-SNAPSHOT/maven-metadata.xml
[WARNING] Could not transfer metadata forge:forge:1.2.16-SNAPSHOT/maven-metadata.xml from/to cardforge-snapshot-repo (ftp.cardforge.org/snapshots): Could not connect to server.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 8:47.744s
[INFO] Finished at: Wed Oct 24 07:29:08 EDT 2012
[INFO] Final Memory: 38M/247M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy (default-deploy) on project forge: Failed to retrieve remote metadata forge:forge:1.2.16-SNAPSHOT/maven-metadata.xml: Could not transfer metadata forge:forge:1.2.16-SNAPSHOT/maven-metadata.xml from/to cardforge-snapshot-repo (ftp.cardforge.org/snapshots): Could not connect to server. Unknown host ftp.cardforge.org -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
logout

[Process completed]

 
the error itself:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy (default-deploy) on project forge: Failed to retrieve remote metadata forge:forge:1.2.16-SNAPSHOT/maven-metadata.xml: Could not transfer metadata forge:forge:1.2.16-SNAPSHOT/maven-metadata.xml from/to cardforge-snapshot-repo (ftp.cardforge.org/snapshots): Could not connect to server. Unknown host ftp.cardforge.org -> [Help 1]
User avatar
Chris H.
Forge Moderator
 
Posts: 6320
Joined: 04 Nov 2008, 12:11
Location: Mac OS X Yosemite
Has thanked: 644 times
Been thanked: 643 times

PreviousNext

Return to Developer's Corner

Who is online

Users browsing this forum: Google [Bot] and 19 guests


Who is online

In total there are 20 users online :: 1 registered, 0 hidden and 19 guests (based on users active over the past 10 minutes)
Most users ever online was 1371 on 09 Feb 2020, 16:22

Users browsing this forum: Google [Bot] and 19 guests

Login Form