It is currently 19 Jun 2019, 23:35
   
Text Size

Request for a definitive answer!

MicroProse's Shandalar Campaign Game, now with new cards & a new look!

Moderators: BAgate, drool66, stassy, Aswan jaguar, gmzombie, CCGHQ Admins

Request for a definitive answer!

Postby Dragoni noir » 25 Apr 2019, 12:15

Hi all,

Lurked for a while, but always had a working version of Magic which scratched both my Shandalar and Multiplayer itches!

Time passes, new computer, lost install files (RIP Korath's updates) and recently fancied getting back into it. Been in touch with Korath himself (mega friendly and helpful) who guided me through all the different releases and development projects to find one which is still available.

Managed to get the 2010 iso version installed in Win10 and multiplayer/manalink working (with some bugs). However I cannot get Shandalar (nor the MTGlauncher, incidentally) to run. Similar problems to others, black screen for a second, then back to a 1024x768 desktop.

I've tried all sorts of compatibility modes/run as admin/folder permissions/clean boot without success, but without an error message, it's hard to know why it's not working.

So I just wanted to ask the knowledgebase here if anyone knows a way to get this running as of April 2019 except running a VM? Or is it a pipe dream for the time being?

Running Win 10 Home Version 1809, OS build 17763.437 on a MSI GS65-8RF.

Thanks
Dragoni noir
 
Posts: 2
Joined: 21 Apr 2019, 21:37
Has thanked: 0 time
Been thanked: 0 time

Re: Request for a definitive answer!

Postby Gibberish » 27 Apr 2019, 22:20

I am not sure what your issue is. Mine installs. I killed the program, open folder, make a short cut of the shandalar icon onto my desktop (the skull) and launch jsut fine. If I use the MTG link I get errors or the icon in tool bar, so I only use the short cut icon
Gibberish
 
Posts: 2
Joined: 27 Apr 2019, 22:18
Has thanked: 0 time
Been thanked: 0 time

Re: Request for a definitive answer!

Postby Dragoni noir » 04 May 2019, 15:52

Thanks for the reply. I can only assume there is something about my OS or other installed software/drivers that Shandalar doesnt like...
Dragoni noir
 
Posts: 2
Joined: 21 Apr 2019, 21:37
Has thanked: 0 time
Been thanked: 0 time

Re: Request for a definitive answer!

Postby gnomefry » 06 May 2019, 16:34

Hi, Dragoni. Your description of the symptoms reminds me of what I see if I try to run Shandalar without excluding it from Windows 10 DEP. Have you done that?

To check, go Control Panel -> System -> System Protection -> (select tab for Advanced) -> Performance Settings -> (select tab for Data Execution Prevention) -> Choose 'Turn on DEP for Essential Windows Programs and Services Only' -> OK. (May prompt you to reboot)

If that allows the game to run, you have the alternate option of turning full DEP back on and excluding just the Shandalar folder *.EXEs.
User avatar
gnomefry
 
Posts: 3
Joined: 28 Dec 2018, 00:44
Has thanked: 0 time
Been thanked: 0 time


Return to Shandalar

Who is online

Users browsing this forum: No registered users and 0 guests


Who is online

In total there are 0 users online :: 0 registered, 0 hidden and 0 guests (based on users active over the past 10 minutes)
Most users ever online was 287 on 31 Mar 2019, 04:11

Users browsing this forum: No registered users and 0 guests

Login Form