It is currently 18 Nov 2018, 12:04
   
Text Size

Bug Reports XMage 1.4.29 SOFTWARE

by BetaSteward

Moderators: LevelX, BetaSteward, North, escplan9, noxx, Aurum, fireshoes, jeffwadsworth, TheElk801, CCGHQ Admins

Bug Reports XMage 1.4.29 SOFTWARE

Postby LevelX » 19 Apr 2018, 19:36

If you have encountered any problems while using XMage 1.4.29 you can post them here.
Please mention who you were playing against: Human or the AI type.
Please describe how you got to that point. A screenshot of the battlefield at the moment something went wrong will be useful too. Otherwise, naming the cards that interacted will suffice. If you get an error log please add that too. Also often does a gamelog file from the mage-client/gamelogs/ folder help to reproduce the problem.



  1. Please use a separate post for each problem/bug.
  2. Don't report here problems concerning to install, start or connect xmage. Only game related problems of using xmage.
  3. Don't report here cards you would like to see implemented. Please report those card requests here:
    http://www.slightlymagic.net/forum/viewtopic.php?f=70&t=19067


Thank you for your help in detecting bugs.

Known Issues:
https://github.com/magefree/mage/issues

Already fixed but not available until the next XMage update
Look here before you post and describe a problem. Often the problems are already fixed and you only have to wait for the next update. If your problem is already mentioned as solved, there is no need to post it in this thread again.
See here: https://github.com/magefree/mage/wiki/Features-and-fixes-not-released-yet
User avatar
LevelX
DEVELOPER
 
Posts: 1674
Joined: 08 Dec 2011, 15:08
Has thanked: 173 times
Been thanked: 373 times

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby Copernicus » 19 Apr 2018, 20:41

Knight of Malice/Knight of Grace
They do not only get +1/+0 when a permanent of the other color is on the battlefield, they also pump other creatures by the same controller.

Vicious offering - doesn't target, doesn't do anything

LevelX: Fixed with 1.4.29V1
Copernicus
 
Posts: 9
Joined: 26 May 2015, 21:47
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby DaLosar » 19 Apr 2018, 21:25

Shalai, Voice of Plenty - Grants everyone hexproof, including herself.

LevelX2: Fixed with 1.4.29V1
DaLosar
 
Posts: 17
Joined: 22 Jun 2012, 06:08
Has thanked: 2 times
Been thanked: 0 time

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby evansteele86 » 19 Apr 2018, 21:35

"unable to connect to server. Wrong client version 1.4.29VO, expecting version 1.4.28V1."
Above is the message I keep getting after updating to the newest version. I even deleted all xmage files from my computer and started from scratch. Same thing happened.

LevelX:To which server are you connecting to. Probably only xmage.de is updated to the new release yet.
evansteele86
 
Posts: 1
Joined: 19 Apr 2018, 21:29
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby jacobcmagic » 19 Apr 2018, 21:43

On Serra's Wings gives +4/+4 instead of +1/+1

LevelX2: Fixed with 1.4.29V1
jacobcmagic
 
Posts: 4
Joined: 12 Mar 2018, 18:57
Has thanked: 0 time
Been thanked: 1 time

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby igniteaxiom » 20 Apr 2018, 00:41

rona doesnt work properly, wont let me cast cards exiled with her.

LevelX: Can't reproduce the problem. Can cast the initial exiled card as also cards exile with the activated ability. Please more details in which situation it did not work (which card, when, etc.).
igniteaxiom
 
Posts: 32
Joined: 03 Feb 2018, 10:08
Has thanked: 0 time
Been thanked: 2 times

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby Kiraxar » 20 Apr 2018, 06:50

Same problem "unable to connect to server. Wrong client version 1.4.28V1, expecting version 1.4.29V1." I'm connecting to xmage.de server. Check version say, that i'm currently using the latest version of xmage.
Kiraxar
 
Posts: 1
Joined: 20 Apr 2018, 06:44
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby Jogmarti » 20 Apr 2018, 10:04

Same issue with my new version not being recognized. I am trying xmage.de

evansteele86 wrote:"unable to connect to server. Wr[url][/url]ong client version 1.4.29VO, expecting version 1.4.28V1."
Above is the message I keep getting after updating to the newest version. I even deleted all xmage files from my computer and started from scratch. Same thing happened.

LevelX:To which server are you connecting to. Probably only xmage.de is updated to the new release yet.
Jogmarti
 
Posts: 1
Joined: 20 Apr 2018, 09:58
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby Keden » 20 Apr 2018, 13:04

Knight of Grace doesn't get +1/+0 while opponent has black permanents.

LevelX2: Fixed beyond 1.4.29V1
Keden
 
Posts: 11
Joined: 22 Feb 2017, 04:11
Has thanked: 2 times
Been thanked: 2 times

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby MalcolmS » 20 Apr 2018, 14:34

Warlord's Fury should say first strike instead of trample

LevelX: Fixed beyond 1.4.29V1
MalcolmS
 
Posts: 55
Joined: 10 Jun 2017, 13:16
Has thanked: 0 time
Been thanked: 2 times

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby faanta » 20 Apr 2018, 16:02

With Muldrotha, the Gravetide and Sakashima the Impostor copying Muldrotha, I should be able to play two cards of each type per turn from my graveyard. Currently, XMage won't let me do that.

From Gatherer: 4/27/2018 If multiple effects allow you to play a card from your graveyard, such as those of Gisa and Geralf and Karador, Ghost Chieftain, you must announce which permission you’re using as you begin to play the card.
faanta
 
Posts: 56
Joined: 21 Sep 2016, 08:10
Has thanked: 1 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby jacobcmagic » 20 Apr 2018, 18:10

Rampaging cyclops doesn't get -2/0 when blocked by two or more creatures

LevelX: Fixed beyond 1.4.29V1
jacobcmagic
 
Posts: 4
Joined: 12 Mar 2018, 18:57
Has thanked: 0 time
Been thanked: 1 time

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby yourdeadtweek » 20 Apr 2018, 23:22

Jaya Ballard's emblem comes up with an error. Here is a screenshot of the error during my game:

Capture.PNG


By the way everything else works. But when I did her ultimate and tried playing any instant or sorcery.

LevelX: Fixed beyond 1.4.29V1
yourdeadtweek
 
Posts: 2
Joined: 20 Apr 2018, 23:16
Has thanked: 0 time
Been thanked: 0 time

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby Zerris » 21 Apr 2018, 02:51

Navigator's Compass' hover text says "target land", but it should be "target land you control".

LevelX: Fixed beyond 1.4.29V1
Zerris
 
Posts: 30
Joined: 01 Oct 2017, 02:26
Has thanked: 1 time
Been thanked: 2 times

Re: Bug Reports XMage 1.4.29 SOFTWARE

Postby cheddarsuave » 21 Apr 2018, 07:53

Benalish Honor Guard is getting +1/+0 for ALL legendary permanents under it's owner's control, not just legendary creatures like it should.

LevelX: Fixed beyond 1.4.29V1
cheddarsuave
 
Posts: 157
Joined: 12 Sep 2016, 00:18
Has thanked: 80 times
Been thanked: 6 times

Next

Return to XMage

Who is online

Users browsing this forum: No registered users and 3 guests


Who is online

In total there are 3 users online :: 0 registered, 0 hidden and 3 guests (based on users active over the past 10 minutes)
Most users ever online was 279 on 11 Jul 2013, 22:03

Users browsing this forum: No registered users and 3 guests

Login Form