It is currently 27 May 2020, 08:47
Text Size

Shandalar 2012 Revisited

MicroProse's Shandalar Campaign Game, now with new cards & a new look!

Moderators: BAgate, drool66, stassy, Aswan jaguar, gmzombie, CCGHQ Admins

Re: Shandalar 2012 Revisited

Postby Grock » 24 Jan 2019, 18:08

Hello there I'm 35 and found an old Magic deck, and reminded me of Shandalar! played it 18years ago... I've found a rusty version that fasten all processes and bypass some screens, life points go down and never go further 11...very buggy!
I have tried your remake and it's good. no crashes.
also there are newest cards than 1999 expansions, right?
why cards doesn't report graphic author?
Anyway well done, thank you very much!!
Posts: 1
Joined: 24 Jan 2019, 17:53
Has thanked: 0 time
Been thanked: 0 time

Re: Shandalar 2012 Revisited

Postby Timetwister » 01 Apr 2019, 17:35

Hello and thank you for keeping Shandalar alive.
The last couple of weeks I have enjoyed playing this version (Revisited) of the game with unmodified decks on a Windows 10 64-bit operating system. I started a new game on Wizard difficulty - not using the savedgames attached to the distribution. Unfortunatelly, in the mid- to late-game I encounter several problems while dueling certain enemies:
- Sedge Troll, Nether Fiend and Archangel, maybe more encounters, after a number of turns (around 10 turns for each player) appear to go into infinite thinking loop at enemy's post-combat phase. This appears no matter if loosing or winning the encounter, and no matter if enemy has 1 or 7 cards on hand. I have tried waiting for over 5 minutes and enemy turn does not end. The cursor is still "rotating". Double-pressing the game field gets cards rearranged, I can move my own cards, etc. but the enemy keeps "thinking" on next move. It does not matter if this phase is marked as "always stop" or not. The only option is to exit the game by ending the process in the Task Manager. Resuming the game and playing the encounter again may or may not have the same result. Restarting computer does not work.
- with some Djinn enemy I got the following error message: "AddCard error: No more room in cd to add a card", and I was asked to seek help on this forum, so here I am.
The deck I aim to play is heavy on card rotation (with Timetwister, Wheel of Fortune), but this issue did not yet happen with any other enemies. I searched the forum and found a workaround but I do not want to have enemy decks modified. Also it does not happen after many turns or card draws - maybe a total of 5 turns where the 1900 card limit is yet to be reached.
Not sure if those issues are specific to this distribution. Please point me to a solution if there is one. I am comfortable with hex-editing should need arise.
Thank you

- Update: playing against Dracur also got the message:
Assertion Error
File-> D:\Newmagic\multiplayer\sid\Minit.c, Line-> 1899
AddCard error: No more room in cd to add a card
Seek assistence in the Shandalar Forum at ... (seriously I can not post url of this forum)
This is in a new game, I do not yet have Timtwister, and this has happened on enemy turn 6.
Posts: 1
Joined: 01 Apr 2019, 16:51
Has thanked: 0 time
Been thanked: 0 time

Re: Shandalar 2012 Revisited

Postby Gibberish » 30 Apr 2019, 17:33

Played the other version, buggy, but had no actual game play issues.

Decided to pick this one up and it was pretty, and faster

Then the other shoe dropped last night, as well as this morning

Hit the ice worm cave, bad guy got a mulligan, I declined to ride his and things went tits up. He got no land, if it even redxrew. Next 8 fights, in same place, every mob dropped no land...ODD! Was a face roll /yawn

This morning, I go to play and mulligan,redraw, no land,,,ODD. I check my black deck and all land in it is no longer in it...or in my inventory. As I check, EVERY land spell is gone that was included in that deck. City of brass x2, gone, Mishra factory x3, gone, and 15 swamps

Not sure if this is an issue others have had, seriously, 14 pages...yeeesh, too much to pour over to seek a confirmation :)

I am unsure if this is a knowen issue or a WTF issue revolving around that dungeon and my random mulligan when fighting or not, but it sure seemed to create a pretty oddball exception. So, starting over I suppose ;)

A side my luck utter trash, sporting a 10 handicapped and the AI is gifted the luck? I can literally predict what card will drop, in most of the dungeon scenarios, in response to my card played. Granted, sense is sense, but when it happens to often to be as if the deck is weighted vs my specific hand, I have to wonder if there is a code issue there as well :)
Posts: 2
Joined: 27 Apr 2019, 22:18
Has thanked: 0 time
Been thanked: 0 time

Re: Shandalar 2012 Revisited

Postby TheAriMan » 08 Jun 2019, 14:55

I'm so glad to have found this game again. And to see that people still play it.

I'm also glad I found this salvaging (if you will) of it, too, as it's incredible to play it with new(ish) cards and Planeswalkers as well. Especially since the version I got before finding this board only has cards as recent as Fate Reforged. Will it be updated with more recent sets in the future?
Posts: 1
Joined: 08 Jun 2019, 14:51
Has thanked: 0 time
Been thanked: 0 time

Re: Shandalar 2012 Revisited

Postby weskone » 13 Aug 2019, 11:43

Hi, I'm new here, I would like to know if you have the link of the shandalar game with all the updates, the last time I played was the normal game with its two updates but now I have seen that they have added many new cards and I would like to play it with these cards Do you have the last link that works correctly for Windows 10 that has these new cards?
Posts: 1
Joined: 13 Aug 2019, 11:25
Has thanked: 0 time
Been thanked: 0 time

Re: Shandalar 2012 Revisited

Postby Reaper » 12 Dec 2019, 18:59

Hello, no new cards, because Korath, pulled the plug on his mods and removed all his links, also he wished it not being reuploaded
Posts: 19
Joined: 13 Jan 2013, 01:20
Has thanked: 2 times
Been thanked: 0 time

Re: Shandalar 2012 Revisited

Postby AMurderOfCrows » 10 Mar 2020, 15:11

I'm playing through using one of the premade saves (Black Wizard/Bog Wraith) and am noticing that the world magic "Tome of Knowledge" doesn't seem to be working properly. Either that, or it doesn't affect cards in the "restricted" list.

I have a deck that is 69 cards currently and any time i try to add in a 5th of any card i have, i'm told i have too many and need to remove anything above the 4th. What's really odd to me though is that the other aspects of that world magic (increasing 40 card deck limits by 1) seems to work fine.

i'm also running into a strange count bug for that deck where even through i have 69 cards, it will show that i have 1 less than that if i click anywhere in the "deck" field.

I almost wonder if the problem i'm having with Tome of Knowledge is related to the deck count problem.

any insights?
Posts: 1
Joined: 10 Mar 2020, 15:04
Has thanked: 0 time
Been thanked: 0 time


Return to Shandalar

Who is online

Users browsing this forum: No registered users and 18 guests

Who is online

In total there are 18 users online :: 0 registered, 0 hidden and 18 guests (based on users active over the past 10 minutes)
Most users ever online was 1371 on 09 Feb 2020, 16:22

Users browsing this forum: No registered users and 18 guests

Login Form