It is currently 25 Nov 2020, 16:34
   
Text Size

Guide to Install and play with XMage

by BetaSteward

Moderators: TheElk801, BetaSteward, LevelX, North, noxx, JayDi, jeffwadsworth, CCGHQ Admins

Re: Guide to Install and play with XMage

Postby JayDi » 10 Dec 2019, 00:43

sivgnpsgfips wrote:i have java and i try to install the launcher but when i open it instead of the launcher it opens a page of the notes and i cant understand whats wrong, i am use i have java, i am sure i have the latest version, and i have Windows 10
Try to run it by launcher file, use that instructions (steps 5-8).
User avatar
JayDi
 
Posts: 299
Joined: 23 Nov 2017, 15:41
Location: Russia
Has thanked: 0 time
Been thanked: 43 times

Re: Guide to Install and play with XMage

Postby thefluff » 22 Dec 2019, 18:32

I'm having trouble registering in the servers, can anyone help?
thefluff
 
Posts: 4
Joined: 22 Dec 2019, 18:29
Has thanked: 0 time
Been thanked: 0 time

Re: Guide to Install and play with XMage

Postby JayDi » 22 Dec 2019, 18:38

thefluff wrote:I'm having trouble registering in the servers, can anyone help?
Try to use other email services (outlook, yahoo, etc). Emails for gmail accounts can may be sent with a delay (hours).
User avatar
JayDi
 
Posts: 299
Joined: 23 Nov 2017, 15:41
Location: Russia
Has thanked: 0 time
Been thanked: 43 times

Re: Guide to Install and play with XMage

Postby thefluff » 22 Dec 2019, 19:55

JayDi wrote:
thefluff wrote:I'm having trouble registering in the servers, can anyone help?
Try to use other email services (outlook, yahoo, etc). Emails for gmail accounts can may be sent with a delay (hours).
I think it's more that I can't connect to a server. It says stuff like "registration is disabled by the server config" and then it will also tell me that the connection is lost from the server.
thefluff
 
Posts: 4
Joined: 22 Dec 2019, 18:29
Has thanked: 0 time
Been thanked: 0 time

Re: Guide to Install and play with XMage

Postby JayDi » 22 Dec 2019, 19:59

thefluff wrote:I think it's more that I can't connect to a server. It says stuff like "registration is disabled by the server config" and then it will also tell me that the connection is lost from the server.
You don't need registration on that server -- just enter any login name without password in connect dialog.

Only xmage.de and xmageplayersmtg.ddns.net servers need registration.
User avatar
JayDi
 
Posts: 299
Joined: 23 Nov 2017, 15:41
Location: Russia
Has thanked: 0 time
Been thanked: 43 times

Re: Guide to Install and play with XMage

Postby thefluff » 22 Dec 2019, 20:28

JayDi wrote:
thefluff wrote:I think it's more that I can't connect to a server. It says stuff like "registration is disabled by the server config" and then it will also tell me that the connection is lost from the server.
You don't need registration on that server -- just enter any login name without password in connect dialog.

Thank you, it looks like it's working now.
thefluff
 
Posts: 4
Joined: 22 Dec 2019, 18:29
Has thanked: 0 time
Been thanked: 0 time

Can't launch client

Postby Kay » 17 Feb 2020, 19:48

Launching CLient results in following stack:

INFO 2020-02-17 20:38:57,779 Starting MAGE client version 1.4.42V4 (build: 2020-02-15 12:17) =>[main] MageFrame.main
INFO 2020-02-17 20:38:57,792 Logging level: INFO =>[main] MageFrame.main
INFO 2020-02-17 20:39:07,111 Loading database... =>[AWT-EventQueue-0] RepositoryUtil.bootstrapLocalDb
INFO 2020-02-17 20:39:09,483 DB: creating cards database =>[AWT-EventQueue-0] MageFrame.<init>
INFO 2020-02-17 20:40:05,211 DB: need to add 233 new sets =>[AWT-EventQueue-0] ExpansionRepository.lambda$saveSets$0
INFO 2020-02-17 20:41:04,460 DB: need to add 38925 new cards =>[AWT-EventQueue-0] CardRepository.lambda$saveCards$0
INFO 2020-02-17 20:42:11,987 Done. =>[AWT-EventQueue-0] MageFrame.<init>
INFO 2020-02-17 20:42:12,033 Loading symbols... =>[AWT-EventQueue-0] ManaSymbols.loadImages
WARN 2020-02-17 20:42:12,158 Symbols can't be load for size 15: SVG fails - 52, GIF fails - 52 =>[AWT-EventQueue-0] ManaSymbols.loadSymbolImages
WARN 2020-02-17 20:42:12,184 Symbols can't be load for size 25: SVG fails - 52, GIF fails - 52 =>[AWT-EventQueue-0] ManaSymbols.loadSymbolImages
WARN 2020-02-17 20:42:12,219 Symbols can't be load for size 50: SVG fails - 52, GIF fails - 52 =>[AWT-EventQueue-0] ManaSymbols.loadSymbolImages
INFO 2020-02-17 20:42:13,695 Loading plugins... =>[AWT-EventQueue-0] Plugins.loadPlugins
INFO 2020-02-17 20:42:13,988 [Game counter plugin, version 0.1] has been loaded. =>[AWT-EventQueue-0] CounterPluginImpl.newPlugin
INFO 2020-02-17 20:42:14,028 [Card plugin, version 0.7] has been loaded. =>[AWT-EventQueue-0] CardPluginImpl.newPlugin
INFO 2020-02-17 20:42:14,042 [Theme plugin, version 0.5] has been loaded. =>[AWT-EventQueue-0] ThemePluginImpl.newPlugin
INFO 2020-02-17 20:42:14,044 Done. =>[AWT-EventQueue-0] Plugins.loadPlugins
INFO 2020-02-17 20:42:21,208 Client start up time: 203 seconds =>[AWT-EventQueue-0] MageFrame.lambda$new$2
INFO 2020-02-17 20:42:21,211 Auto-connecting to xmage.de =>[AWT-EventQueue-0] MageFrame.autoConnect
INFO 2020-02-17 20:42:23,571 Connect: connecting to server xmage.de:17171 =>[SwingWorker-pool-6-thread-2] SessionImpl$5.work
INFO 2020-02-17 20:42:25,448 Connect: DONE =>[SwingWorker-pool-6-thread-2] SessionImpl$5.work
INFO 2020-02-17 20:42:25,454 Logging: as username Algo to server xmage.de:17171 =>[SwingWorker-pool-6-thread-3] SessionImpl$4.work
INFO 2020-02-17 20:42:25,811 Logging: FAIL =>[SwingWorker-pool-6-thread-3] SessionImpl$4.work
ERROR 2020-02-17 20:42:38,448 Ping failed: Algo Session: 5c4o12o-w8r8wz-k6qv84hk-1-k6qv84qg-4 to MAGE server at xmage.de:17171 =>[pool-1-thread-1] SessionImpl.ping
FATAL 2020-02-17 20:42:38,452 Server error =>[pool-1-thread-1] SessionImpl.handleMageException
mage.MageException: Ping failed


after that the new window stops responding and needs to be terminated by the OS. Further attemts to Launch Client do nothing - empty stack, no new window. Restarting the PC or brand new download do nothing. Any help greatly appreciated!
Kay
 
Posts: 1
Joined: 17 Feb 2020, 19:35
Has thanked: 0 time
Been thanked: 0 time

Re: Can't launch client

Postby JayDi » 21 Feb 2020, 09:34

Kay wrote:after that the new window stops responding and needs to be terminated by the OS. Further attemts to Launch Client do nothing - empty stack, no new window. Restarting the PC or brand new download do nothing. Any help greatly appreciated!
It's auto-login problem. Use that instructions to fix it.
User avatar
JayDi
 
Posts: 299
Joined: 23 Nov 2017, 15:41
Location: Russia
Has thanked: 0 time
Been thanked: 43 times

Re: Guide to Install and play with XMage

Postby gabrielduarte » 25 Mar 2020, 03:39

I keep geting this message "MageFrame quit unexpectedly" after trying to start the Client. If I ignore it, the client won't start. Running MacOs Sierra 10.9 here.

Last line:
Expected in: /usr/lib/libSystem/B.dylib
gabrielduarte
 
Posts: 1
Joined: 25 Mar 2020, 03:34
Has thanked: 0 time
Been thanked: 0 time

Re: Guide to Install and play with XMage

Postby smives » 25 Mar 2020, 15:29

I have installed java and xmage and downloaded the java and the xmage versions through the launcher but when I try to launch it I get this message:
Error: opening registry key 'Software\JavaSoft\Java Runtime Environment'
Error: could not find java.dll
Error: Could not find Java SE Runtime Environment.
Any idea? Am I being stupid or is their something I am missing? I have used the links provided on the website as well as my looking them up myself and am just confused.
I have played before on Mac and never had these problems.
smives
 
Posts: 1
Joined: 24 Mar 2020, 18:31
Has thanked: 0 time
Been thanked: 0 time

Re: Guide to Install and play with XMage

Postby miso222 » 01 Apr 2020, 15:58

Hi, Im trying to run xmage on Mac, I did what was needed, installed java, then xmage launcher and downloaded newest version. I also did permission in terminal with chmod +x ..., everything went fine, yet when im trying to launch client, i get following error, i dont know what to do, completly lost. Can anyone help me what im doing wrong or how to fix this?

thx in advance

michael
Attachments
Screen Shot 2020-04-01 at 17.54.25.png
miso222
 
Posts: 1
Joined: 01 Apr 2020, 15:49
Has thanked: 0 time
Been thanked: 0 time

Re: Guide to Install and play with XMage

Postby Shiva101 » 08 Apr 2020, 20:31

Hi there,

new to Xmage, was trying to install it and I keep getting this error. I'm assuming the website isn't down, any idea what I'm doing wrong?
Attachments
Capture.PNG
Shiva101
 
Posts: 1
Joined: 08 Apr 2020, 20:27
Has thanked: 0 time
Been thanked: 0 time

Re: Guide to Install and play with XMage

Postby Papamax » 16 Nov 2020, 09:37

when i try to open the xmagelauncher.jar it doesnt appear to do anything no command windows or error messages and no processes are created in task manager ive tried opening it using "openwith" javaw.exe and java.exe ive tried uninstalling and reinstalling java to no success i am running java 8u271
Papamax
 
Posts: 1
Joined: 16 Nov 2020, 09:29
Has thanked: 0 time
Been thanked: 0 time

Re: Guide to Install and play with XMage

Postby JayDi » 16 Nov 2020, 15:25

Papamax wrote:when i try to open the xmagelauncher.jar it doesnt appear to do anything no command windows or error messages and no processes are created in task manager ive tried opening it using "openwith" javaw.exe and java.exe ive tried uninstalling and reinstalling java to no success i am running java 8u271
1. Create \games\xmage\ folder;
2. Download and copy launcher.jar file from http://xmage.de to that folder;
3. Download run-launcher file and UNPACK it to xmage game's folder (step 5 from that instructions).
4. Run launcher by run-launcher cmd file.
User avatar
JayDi
 
Posts: 299
Joined: 23 Nov 2017, 15:41
Location: Russia
Has thanked: 0 time
Been thanked: 43 times

Previous

Return to XMage

Who is online

Users browsing this forum: No registered users and 15 guests


Who is online

In total there are 15 users online :: 0 registered, 0 hidden and 15 guests (based on users active over the past 10 minutes)
Most users ever online was 1371 on 09 Feb 2020, 16:22

Users browsing this forum: No registered users and 15 guests

Login Form